Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Thu rsday, 5 March

8am

8am

8:13am

8:26am

8:39am

8:52am

8am

8am

8:15am

Worlds of Work
Salon E

Navigating Contemporary American Work Force, Kinship and
Federal Holidays

» Mr. Cameron Farrar

A Relational Theory of Job Insecurity
» Dr. Andrew Fullerton

Working from Home and Work-Life Balance: Variation Across
European Societies Over the Course of the Covid-19 Pandemic

» Dr. Christel Kesler, Dr. Hilary Silver

Fishermen as Artists: Cultural Production in Times of Change
» Ms. Allison Wigen

Mead and Burawoy Against Weber, Durkheim, and Parsons:
Chicago Versus Harvard, Social Behaviorism Versus Social Theory

» Dr. Mark Gould

Social Mediations on Mental Health
London 2

“They're not reaching students the way they want to be reached":
A study of College Students’ Experiences with the Climate and Use
of Campus Mental Health Services

» Dr. Hana Gebremariam

Bridging or Widening the Gap? A Scoping Review of Al Mental
Health Support and Mental Health Disparities

» Dr. Min Li

Powered by Ex Ordo, everything you need to run a research conference.

8:30am

8:45am

8am

8am

8:15am

8:30am

8:45am

8am

8am

8:12am

“When Am | Going to Find Someone Who Understands?":
Navigating the Mental Healthcare Landscape in College

» Ms. Charlotte Perez

The Intersecting Effects of Gender, Race and Discrimination on
Mental Health: A Cross-Sectional Study of Depressive and Anxiety
Symptoms Among U.S. Adults.

» Mr. John Whesu

Rural Worlds
Salon C

Spatially Structured Friends: How Residence and Internet Use
Shape the Peer Relations of Chinese Adolescents

» Ms. Fei Xie

Financial Portrait of Rural Americans
» Prof. Paromita Sanyal, Prof. Matthew Brooks

Structured Absence: Race, Disinvestment, and the Geography of
Rural Inequality

» Mr. Eashwar Krishna, Ms. Kezia Smith, Ms. Theja Suresh Nagan, Mr.
Pranav Yerra

Expected Educational Returns, School Dropouts, and Youth
Migration: Causal Analysis of Rural Youth Using a Genetic
Approach

» Ms. yuxin liu

Digital Worlds
Penn Quarter

The Rise of Higher Education Influencers: Digital Discourses on
Contemporary College Life

» Mr. Olugbenga Joseph

The Moral Economies of Influencer Culture: Visibility, Value, and
Intersectional Precarity

» Mr. Waris Ahmad Faizi
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8:24am

8:36am

8:48am

8am

8am

8:15am

8:30am

8am

8am

Social Solidarity in the Digital Era
» Dr. Yuying Shen

Digital Diasporas under Crisis: Transnational Asian Online
Communities and the Politics of Solidarity, 2018-2023

» Ms. Angi Hu

African Youth: Leveraging the Demographic Dividend Through
Unconventional Political Participation in the Digital Space and
Street Protests

» Prof. Linda L. Semu

Care, Capacity & Connection
Salon D

Aging together: Community care as resistance to privatized elder
care

» Ms. Erica Janko

Siblings Caring for Parents across Policy Regimes: Exploring and
Explaining the Variation in Gender Gaps in Europe

» Dr. Natalia Sarkisian, Dr. Naomi Gerstel

Aging and Care Capacity: Evaluating Puerto Rico’s Nursing Home
Infrastructure

» Ms. Rutwa Shah, Dr. Fernando Rivera

Ethnic Bonds & Social Belonging
Salon A

Halal New York: How Success Happens for Second-Generation
American Muslim Women in New York City

» Ms. Serra Kocak

Powered by Ex Ordo, everything you need to run a research conference.

8:13am

8:26am

8:39am

8am

8am

8:13am

8:26am

8:39am

8:52am

8am

Integrative Pathways of Ethnic Retention: Gendered Dimensions
of Cultural and Religious Continuity

» Dr. Maheen Haider

Contested Belongings: Race, Ethnicity and Religion in Campus
Muslim Organizations

» Dr. Aleezay Khalig

Diverse Ties, Risky Bonds: A Multidimensional Analysis of Social
Capital and Substance Use Among Adolescents in China

» Mr. Chengzhe Xu

Family Worlds
Salon B

Public Marriage, Private Children: Law, Family, and the
Privatization of Dependency in Comparative Perspective

» Mx. Bela August Walker

Gender Ideology and the Desire to Marry in China: Examining the
Gender Attitudes of Young Women and Men

» Dr. Sampson Blair, Dr. Timothy J. Madigan, Ms. Sha Luo

Rebuilding Family through Friendship: Estrangement, Care, and
Friendship Strategies among Emerging Adults

» Ms. Madison Green

Free Time Poverty or Riches? The Quantity and Quality of Leisure
Among Parents in the 21st Century

» Dr. Melissa Milkie

Beyond the Breadwinner: Exploring the Work-Family Interface
across Ethnicity and Class

» Dr. Michael Ramirez

Student Experiences in Higher Education
London 1
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8am

8:15am

8:30am

8:45am

8am

8am

8:13am

8:26am

THE IMPACT OF ACCULTURATION STRESS ON AFRICAN
IMMIGRANTS IN THE UNITED STATES: A QUALITATIVE STUDY AT
NORTHERN ARIZONA UNIVERSITY.

» Ms. Modesta Owusu Agyemang

Refuting the Homogeneity of Chinese International Students’
Academic Experiences: An Exploratory Study at a U.S. Liberal Arts
College

» Ms. Ke Yao

Navigating Housing in New York City: Understanding
international student housing market

» Mr. SHUHAO CHANG

What Do Students Want From Mentors? Centering Undergraduate
Voices to Define Best Practices in STEM Mentoring

» Ms. Mariam Machabeli ", Mr. Eralp Karduz, Dr. Danielle Morales

Communities in Contention Mini-Conference: Immigration, Borders,
and Transnational Communities

Salon 2

Nodes of Transnationalism: The Spatial Dynamics and Heterotopic
Nature of Remittance Service Providers in the Washington, D.C.
Metropolitan Area

» Mr. Matt Hernandez

This is What Community Looks Like: The Formation of a Chinese
Ethnic Community under Urban Redevelopment

» Ms. Victoria Tran

The (Ab)Uses of Anti-Gentrification Sentiments: How MAGA
Contested Progressive Claims to an Urban Immigrant Community

» Mr. Zachary Del Rosso

Powered by Ex Ordo, everything you need to run a research conference.

8:39am

8:52am

8am

8am

8:13am

8:26am

8:39am

8:52am

8am

8am

From Dispossession to Dissent: Dalit Contention and the
Reimagining of Socio-Political Belonging in the Kerala Model of
Development

» Mr. Arvind Geetha Christo

From Ballot Box to Block Party: Political Culture Construction and
Identity Work in Divided Cities

» Prof. Jennifer Garfield-Abrams

Teaching Sociology Mini-Conference: Reflections on the
Contemporary Conditions of Teaching

Salon 1

Teaching Sociology Amid the Collapse of the Liberal Project
» Dr. Sergio Cabrera Cabrera

Responding to Academic Censorship by Resisting Pedagogical
Norms and Embracing Critical Pedagogies

» Ms. Davina Barbee

My “Pocket Professor”: Understanding College Student
Perceptions of Al for Learning and Completing Assignments

» Dr. Misty Curreli, Dr. Laura Heisick

The Meaning of Student-Centered Teaching: Power, Practice, and
Pedagogy
» Dr. Melanie Lorek, Dr. Sara Martucci

Understanding Paradigms to Enhance Student Engagement in
Sociology Courses

» Dr. Andrew Plotkin

Military Sociology and Worldmaking Mini-Conference: Warfare,
Economy and Governance

Salon 3
Chaired by: Dr. Alan Dugger

The Sociological Dimension of "Permanent Security"
» Dr. Yagil Levy
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8:15am

8:30am

9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

9:43am

Costs of War: Political Economy in Russia, 2022-2025
» Prof. |effrey Hass

Coercion and Exploitation: The Mechanism of Aid Hijacking in
Conflict Areas

» Dr. Ori Swed, Dr. Daniel Burland

Precarious Work
Salon E

Bridges of Precarity, Borders of Privilege: Indian Immigrant Tech
Labor Activists’ Boundary Work in the US

» Dr. Rianka Roy

Does Precarious Work Alter the Immigrant Health Advantage? A
Comparison by Education level

» Ms. Radhika Prasad

Articulating Caste: Incorporation of Caste in Domestic Workers’
Movement in India

» Dr. Sonal Sharma

Social Isolation among U.S. Workers: the Effects of Work
Arrangements, Schedule Control, and Job Demands

» Dr. Deniz Yucel, Ms. Gamze Ipek

Transforming Political Contexts
London 2

Bipartisan Support for Anti-Transgender Policies: Justifications
and Frameworks

» Mx. Amanda |ane

Social Support Among U.S. Transgender Adults: Disaggregating
Gender and Sexuality

» Mx. Janus Chidester

Powered by Ex Ordo, everything you need to run a research conference.

9:56am

10:09am

10:22am

9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

Meaning-Making at the Margins: American Understandings of
Socialism and Communism in a Politically Polarized Landscape

» Mx. Garrett Washington

Disruption Through Consumption: How Consumers are
Reimagining the World Through Their Consumptive Choices

» Dr. Meredith Katz

Party-State Urbanism: Coevolution of Local State Capacity and
Strategic Alliances in Shenzhen

» Ms. YUNHAN WEN

Foreign Born, Race, and Discrimination
Salon C

Fear of Crime Victimization Among the Foreign-Born in the United
States

» Ms. Samiya Haque

Labor Force Participation of Foreign Born and Native Born White
Women, 2021-2023

» Dr. Veena S. Kulkarni

Household Earnings and Extension: Reexamining the roles of
Ethnicity and Nativity Statuses among the Six Major Asian Groups
in the Post-Pandemic Period

» Dr. Veena S. Kulkarni

The Effect of an Individual's Race on their Hypertension Status: An
Analysis Rooted in Nativity and Discrimination

» Ms. Tori Chace, Dr. Elizabeth Durden

Al and Its Impacts
Penn Quarter

The Rise of Artificial Intelligence as a Potential Amplifier of
Neoliberal Malaise: Alienation, Despair, and Violence in 21st
Century America

» Dr. Luigi Esposito, Dr. Fernando Perez
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9:45am

10am

10:15am

9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

Will artificial intelligence yield 'real’ worker insecurity?

» Dr. |effrey Dixon

“Al is NOT Amazing”: Academic Elitism and the Challenge of Al
» Ms. Sena Kaplan, Mr. Yingyu Zang

Medical Authority in the Age of Al: How Experts Define and
Defend the Boundaries of Doctoring

» Ms. Anne Kavalerchik

Ruptures & Change
London 1

Tradition and Technology: The Covid-19 Pandemic as a Catalyst for
Lasting Transformation in American Jewish Communal Practice

» Ms. Blake McCabe

Towards a Theory of Shocks and Their Impacts on Workplace
Contention

» Ms. Ewa Protasiuk

Process, Rupture, and the Political Temporality of January 6th,
2021

» Mr. Adam Brown

Diminishing Opportunities: Adapting to the Changing Dynamics of
Drug Dealing in Mexico City

» Dr. Piotr Chomczynski, Dr. Roger Guy

Sexual Harms & Sexual Socialization
Salon A

Latinas condemn machismo cultural framework and macho
practice for gender domination and sexual violence

» Dr. Amanda Konradi, Ms. Norma Ferraro

Powered by Ex Ordo, everything you need to run a research conference.

9:45am

10am

10:15am

9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

Male College Victims of Rape

» Dr. Arielle Kuperberg, Dr. David DiMarco, Dr. Ryan Savitz, Dr. Jennifer
Lundquist

“Talk about masturbating? Please! You're Pushing It”: Modesty,
Masturbation and Sexual Socialization within New York’s Haredi
Communities

» Ms. Gloria Fortuna, Dr. Jennifer Hirsch, Dr. Jessie Ford, Ms. Alicia Jen

Behind Closed Doors: What Shapes American Attitudes Toward
Premarital Sex?

» Mr. Md Akter Hossen

Health & Wellbeing
Salon B

Screens as Shelter? An Empirical Study on Video Consumption,
Mental Health, and Crime among U.S. Young Adults

» Mr. chenkai niu

The Labor of Love and the Consumption of Care: Reproductive
Work, Emotion, and Agency in Domestic Life

» Ms. Pang-Yuan Chen

Effects of Immediate Family Loss on Health and Well-being
» Ms. Ting Hong, Mrs. Rose Anderson

Scholarships and self-esteem among low-income high-achieving
students

» Ms. Dayna Valek

Communities in Contention Mini-Conference: Intersectionality,
Identity, & Social Movements

Salon 2

Whiteness overlooked: An ecofeminist-intersectional queer
perspective on campus nature.

» Dr. Vanita Naidoo

Page 5


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Thursday, 5 March

9:45am

10am

10:15am

9:30am

9:30am

9:30am

9:45am

10am

Master's of The Universe: Men's Rights Activists and Collective
Identity

» Prof. E] Néel

Quasi-Religious Repertoires of Contention: Sectarian and
Integrative Mobilization in TPUSA and Groyper Movements

» Ms. Jessica Ridge, Prof. Richard Zdan

ANTI-INTERSECTIONALITY
» Dr. K.L. Broad

Teaching Sociology Mini-Conference: Enhancing Scholarly Teaching:
Publishing and Learning with TRAILS

Salon 1

Enhancing Scholarly Teaching: Publishing and Learning with
TRAILS

» Dr. Walter Carroll

Military Sociology and Worldmaking Mini-Conference: Military-
Civilian Dynamics

Salon 3

Chaired by: Mr. Alex Picardo

The Cost of Vulnerability: Estimating the Societal and Economic
Impact of Poor Transitions from the UK Armed Forces

» Ms. Linda Slapakova, Ms. Catherine Galley

“YOU GOTTA DO WHAT YOU GOTTA DO": Extending the Theory of
Access to Explain Complexities in Veteran Food Assistance

» Dr. Jimmy |. Esquibel

Navigating Military Disclaiming Discourse: Broke Dicks and Vet
Bros

» Dr. Steven Dashiell

Powered by Ex Ordo, everything you need to run a research conference.

10:15am

9:30am

9:30am

9:43am

9:56am

10:09am

11am

T1am

11am

T1am

Republicanism as a value - Reconceptualizing the Republican
contract in Israel

» Dr. Dana Grosswirth Kachtan

Sociology of Reproduction Mini-Conference: Abortion |
Salon D

Abortion Support Organizations Assessment of Risk Helping
Abortion Seekers in Abortion Restrictive Landscapes

» Dr. Tracy Weitz, Dr. Ophra Leyser-Whalen

Between Law and Conscience: A Longitudinal Analysis of Italy’s
Abortion Law

» Ms. Payton Gannon, Dr. Danielle Pullan

Policing Providers: Legal Impacts on Abortion and Opioid
Provision

» Prof. Liz Chiarello

Aborting Stare Decisis: Conservative Justices Eschew Precedent to
Restrict Abortion

» Prof. Deborah Machalow

Panel: The Unlevel Playing Field: Exploring the Connection of Race
and Sport

London 1

The Unlevel Playing Field: Exploring the Connection of Race and
Sport

» Dr. Katelyn Foltz, Ms. Reignah Johnson, Ms. Onyekachukwu Arah, Dr.
Earl Smith, Dr. Angela Hattery, Dr. Kris Marsh

Restorative Justice & Repair Practices
London 2

Restorative justice practices, proactive policing, and the culture
of security in Brazil

» Dr. Helena Wilke
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11:15am

11:30am

11:45am

T1am

T1am

11:13am

11:26am

11:39am

11:52am

Symbolic Compliance and Restorative Justice in School Discipline
Reform

» Ms. Isabella Burns

Whiteness and Peace
» Dr. |effrey Toussaint

Criminal (in)justice?: A frame analysis of the impact of family
member incarceration on worldview

» Dr. Allegra Pocinki

Professional Paths & Pathways
Salon C

Who Stays on the Path to Medicine? Predictors of Occupational
Aspirations Over Time

» Dr. Hiromi Ishizawa

Aspiring Physicians: The Popularity of Medicine as a Career Goal
in 39 Countries, 2000-2022

» Prof. Jerry A. Jacobs, Prof. Joanna Sikora

Innovative Pathways to Entrepreneurship: Perspectives from
Marginalized Communities

» Dr. Michelle Dromgold-Sermen, Ms. Abigail Naidoo, Ms. |anna
Tosson, Dr. Toyah Miller

Human Capital in the Making: Learning Individual Responsibility
and Competition in STEM Education

» Dr. Timothy Sacco

Building Engagement and Professional Identity: Student
Experiences with Multiple High-Impact Practices in a Criminal
Justice Capstone

» Dr. |essica Hodge

Powered by Ex Ordo, everything you need to run a research conference.

11am

T1am

11:15am

11:30am

11:45am

11am

T1am

11am

T1am

11:15am

Claimsmaking, Mobilizations and State Power
Penn Quarter

Cognitive Heterogeneity and Lay Theories of Regulatory Power
» Mr. Gabriel Lévesque

Whose Movement?: Black Millennial Perceptions of the
Beneficiaries of BLM

» Dr. Simone Durham

Language as Criminality: State Discourse, Surveillance, and
Linguistic Policing
» Ms. Amy Katuska, Dr. James Love

U.S. Empire in "Black Reconstruction": Du Bois' critique of U.S.
imperialism in the outcome U.S. Reconstruction

» Dr. Julia Bates

Doing Sociology in the DMV in a Shifting Sociopolitical Landscape
Salon E

Doing Sociology in the DMV in a Shifting Sociopolitical Landscape

» Dr. Kim Blankenship, Dr. Jennifer Turner, Dr. Gay Young, Dr. Carolette
Norwood, Dr. Jason Smith, Dr. Yuki Kato, Dr. Judy Lubin

Communities in Contention Mini-Conference: Immigration, Race, &
Labor

Salon 2

'This is Not Our Fight': Black TikTok Discourse on Immigration
Raids in Summer 2025

» Dr. Luis Tenorio, Ms. Se'Maj Griffin

Good Jobs, Bad Ladders: Sequential Shocks and the Racialized
Reordering of Work in New Immigrant Destinations

» Prof. Laura Lopez-Sanders
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Continued from Thursday, 5 March T1am Military Sociology and Worldmaking Mini-Conference: Digital
Warfront Dynamics

Salon 3
11:30am The challenge of a class: the prospects of immigrant and Chaired by: Dr. Karin DeAngelis
American workers’ unity in an era of cultural and political division
» Mr. Gabrie| Ulbricht Ferreira 11am Uninvolved? OSINT Experts, Pundits, and the Indirect
Participation in Contemporary Warfare
11:45am Gringo Go Home: Exploring The Neoliberal and Racialized Politics » Ms. Virginia Parker
of Immigration in Mexico
» Mr. Samuel Showalter 11:15am The Influence of Xenophobia and Social Media Use on Attitudes
Toward Counter-Terrorism in Cadets
11am Teaching Sociology Mini-Conference: Contemplating Positionalities » Ms. Lily Haeberle, Ms. Michaela Workman, Dr. Ryan Kelty
in Teaching
Salon 1 11:30am Battles Over Minds: The Cognitive Frontier of 21st Century
Conflict
11am “1 Still Have Them": Using My Experience as a Mother to Help » Prof. Lukasz Kamiensid
Students Develop Their Sociological Imagination
» Dr. Elizabeth Clifford 11am Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Discourse and
Knowledge-making
11:13am Senior Capstone as Rite of Passage: Reflections on Guiding Salon B
Working-Class Students through the Research Process
» Dr. lamie Longazel 11am A Pedagogy of Animacy for Intimacy: Embodiment, Seeing,
Drawing and Knowing
. . . . Dr. Phoebe Godf
11:26am Teaching Introductory Sociology as an International Graduate » =L 10ebe Sodlle
Student in an Urban Public University: Critical Pedagogy in
Practice 11:13am Wastelanding, Environmental Degradation, and Knowledge
» Mr. Eralp Karduz, Ms. Mariam Machabeli® Manipulation in Avatar: The Last Airbender

» Mr. Khaled Dakak

11:39am What Makes Our School Unique?: A Qualitative Analysis of
Community College Student Driven Data

» Prof. E] Néel

11:26am Historicizing Ecological Crisis; Ruling Ideas and the Geoculture of
Planetary Management

» Mr. Engin Yilmaz

11:52am Exploring the Instructional Effectiveness of Contemplative 11:39am Where Intersectional Is Embodied: Grief and Grieving as Sites of
Pedagogy Sociological Revelation in Environmental Research
» Dr. Jaime Deluca, Dr. Samuel Clevenger » Mx. Kate McNeely
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11:52am

T1am

T1am

11:13am

11:26am

11:39am

T1am

12:30pm

12:30pm

12:45pm

Clam in a Bottle: Cultivating Multispecies Climate Resiliency
» Ms. Abby Westberry

Sociology of Reproduction Mini-Conference: Abortion Il
Salon D

“I'm Trusting You with My Entire Life”: Impersonal Ties, Situated
Trust, and Pathways to Abortion Care Post-Dobbs

» Prof. Claire Decoteau

Out of Reach: How Geography and Policy Shape Confidence in
Abortion Access in Post-Dobbs America

» Ms. Claire Reardon

"I didn't know | was allowed to talk about it": Investigating men's
accounts of abortion

» Dr. Andrea Becker, Dr. Nicholas Mark

Women's Place is in the Statehouse: The Politics of Presence in
Discourse before and after Dobbs

» Dr. Danielle Pullan, Ms. Nikolina Klatt, Ms. Payton Gannon

DC 2026 Institute on Teaching Social Action
Salon A

Moral Frames and Ethical Worldmaking
London 1

The Spiritual and the Speculative Boundar: Negotiating Faith,
Space, and Social Order in the Sacred Geography of Delhi’s
Dargahs

» Mr. Animesh Dev

Feminine Subjectivity and Ethical Worldmaking in the Giilen and
Rifai Movements

» Dr. Hale Inanoglu

Powered by Ex Ordo, everything you need to run a research conference.

Tpm

1:15pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

12:45pm

Tpm

The Spatial-Temporal Framing of Moral Action: Insight from the
Case of Volunteer Tourism

» Dr. Netta Kahana

Silent Struggles: How Purity Culture Shapes Masculinity,
Emotional Well-Being, and Relational Health

» Dr. Danielle Ficco

Housing and Systems of Inequality
London 2

Racialized Stigma and Climate Risk: Geographies of Housing
Financialization in Boston

» Dr. Rachel McKane, Ms. Stephanie Garlow

“We all belong here": Bridgeport residents respond to anticipated
public housing demolition

» Dr. Patricia Lewis, Dr. Vanessa Liles

The Concept of Housing Trauma
» Dr. Rachael Woldoff

Gun Violence and Its Roots in Racial Capitalism
» Prof. Tanya Golash-Boza

Organizational Encounters
Salon C

Mining the Gap: Uncovering and Navigating Discrepancies
Between Organizational and Individual Narratives

» Dr. Garry S. Mitchell, |r., Dr. Daphne Penn

Constructing Compliance: Rethinking Legal Endogeneity Through
the Case of Policing

» Ms. Charlie Pollard, Mrs. Amanda Pierson

Fiscal Bureaucrats in Public Sector Organizations
» Ms. Sandra Okonofua
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1:15pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

12:45pm

Workplace characteristics, Job Satisfaction and Labor Supply: Do
Aspirations matter?

» Dr. Tufan Ekici

Contesting Ableism
Salon E

Structural Ableism: Intersectionality and Adult Well-being in the
United States

» Dr. Diane Shinberg

Research as worldmaking: apprehending ableism creatively in
Aotearoa New Zealand

» Dr. Penelope Carroll, Dr. Linda Madden, Prof. Karen Witten, Dr.
Amanda Lowrie, Mr. Kerry Hiine

The Invisible Patient: Blackness, Disability, and Structural
Inequities in Modern Healthcare

» Ms. Jamilah Watson

Challenging the Desexualization of Disability: Romantic and
Sexual Relationships Among Youth with ADHD

» Dr. Danielle Morales, Mr. Eralp Karduz, Ms. Aaliyah Hassan

Race, Place, and Black Futures
Penn Quarter

The New BMF: Black Male Futures - Visions beyond Classrooms,
Cells, and Cubicles. What will shape the pursuit & perception of
Black boy brilliance in 2035?

» Mr. Daryl Bodrick Il, Mr. Jaden Smith

The Blueprint of Black Mecca: An in-depth look at race, class and
placemaking in Atlanta, Georgia

» Dr. Jonathan Grant

Powered by Ex Ordo, everything you need to run a research conference.

Tpm

12:30pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

1:30pm

12:30pm

12:30pm

The Pernicious Effects of Territorial Valorization
» Prof. Dana Kornberg

Communities in Contention Mini-Conference: Lunch
Salon 2

Teaching Sociology Mini-Conference: Theory, Self, and Society:
Innovations and Reflections

Salon 1

Students Building Sociological Theories of A Future Economy
» Dr. Daina Eglitis

Feeling and Doing Sociology: Using Emotions and Classroom
Activities to Develop Critical Thinking and Personal Relevance

» Dr. Phoebe Godfrey, Mr. Chenkai Niu

Sociology-as-Self-Help
» Dr. Jacob Boersema, Ms. Madion Shi

From Sociological Imagination to Sociological Attention: Revisiting
Mills in the Digital Age

» Dr. Max Greenberg

The “Boston” Sociological Tour: Teaching Sociology through Place
and Story

» Mr. Danny Daniel Mollericona Alfaro

Military Sociology and Worldmaking Mini-Conference: Culture,
Identity, and Service

Salon 3
Chaired by: Jeanne Kimpel

Beyond the Flag: The Faces of Patriotism in the 21st Century
» Ms. Alyssa Figueroa
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12:45pm

Tpm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

2pm

Between Greedy Institutions: Gender, Family, and Belonging in
Military Spousehood

» Mr. Seth Behrends

Parallel Agents of Socialization: A Comparative Visual
Autoethnography of Worldmaking on a Military Base and a
University Campus

» Mr. Ryan Sermon

Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Social Movements and
Mobilizations

Salon B

Regulatory processes and the politics of environmental expertise
» Mr. Gabriel Lévesque

Living Otherwise: Temporal Reorientations in Climate Resistance
» Mrs. Daphne Fietz

Framing Across the Divide: Environmental Movement
Organization Appeals for Support to Address Climate Change

» Dr. Fletcher Winston

Climate (in)Action, Anti-Reflexivity Theory, and the "Missing
Middle"

» Dr. Chris Colocousis, Prof. Grace Smith

Lunch Break
Salon D

Stratifying Processes & Institutions of Higher Education
London 1
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2pm

2:15pm

2:30pm

2:45pm

2pm

2pm

2pm

2pm

2:15pm

2:30pm

How selective college admissions strategy shapes applicants’
understandings of diversity

» Dr. Tiffany Huang

Worldmaking from the Margins: An Autoethnographic Study of
Gig-Based Admissions Reading

» Mr. Ryan Sermon

"You Don’t Want to Go Too Deep": How Applicants Make Race
Legible in College Essays

» Dr. Sarah Iverson, Mx. Adrian Davis, Ms. Sarah Mondesir, Mx. Garrett
Washington

Who Belongs? Black Mixed-Race Identity and Micro-Contexts at
Differing Institutional Types

» Ms. Eliana Gagnon

AMC: Unwelcome Shores. Black Refugees in America, by Bernadette
Ludwig

Salon E

AMC: “Unwelcome Shores. Black Refugees in America”

» Dr. Bernadette Ludwig, Dr. Philip Kasinitz, Dr. Derron Wallace, Dr.
David Haines, Dr. Karen Okigbo

New Directions in the Study of Migration
Salon C

The State in Motion: Rethinking the Role of Migrant-Sending
States

» Ms. Umida Hashimova

Genetic Selectivity in Migration: Polygenic Insights into
Heterogeneous Outcomes of Domestic Migration in the US

» Ms. yuxin liu
Feeling Bodies. The Affectivity of Moving in Contemporary Afro-

Caribbean Transit Migration Across the Americas.
» Mr. Pedro Valdez Castro
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Continued from Thursday, 5 March

2:45pm

2pm

2pm

2:13pm

2:26pm

2:39pm

2pm

2pm

2:15pm

2:30pm

Migrant legislators: the Mexican State negotiating its legitimacy
before its diaspora amid Trumpism

» Mr. Maurizio Guerrero

Worldmaking, Religion, and Civic Action
London 2

Acting in Good Faith: A Qualitative Study to Investigate How
Faith-Based Social Action Promotes Skills for Civic Engagement

» Mr. leremy Szteiter

Rewiring Civic Life: How Working from Home Changes
Volunteering — Longitudinal Evidence from the UKHLS, 2009-2023

» Ms. Ying Qu

Imagining a Catholic Queer World: Hope, Realism, and
Concessions

» Mr. Lucas Sharma

The Religiosity of Labor Unions: An Alternative to Traditional
Religious Spaces

» Ms. Quinn Pierson

Political Contestations: Worldmaking and World Loss
London 1

Private Actor Involvement in Refugee and Immigration Policy
» Dr. Ruoya Huang

We Were Almost Emancipated, Is It Slipping Away? The Paradox of
Law, Rights, and Reform in Bangladesh’s (Democratic) Transition

» Ms. Jeba Humayra

Political content creating at the boundaries: Hysteresis,
transposed Logics, and the politics of cross-field collaboration

» Dr. Yena Lee
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2:45pm

2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

2pm

2:13pm

Nationalism as an option: Korean Chinese identity practice
between Chinese nationality and Korean ethnicity

» Ms. Lixiang |in

Communities in Contention Mini-Conference: Economic Inequality &
Political Fragmentation

Salon 2

“The Money | Get is Like Oxygen to Me": Preliminary Findings from
the Fairfax County Economic Mobility Pilot

» Dr. Elizangela Storelli, Dr. Amy Best, Mrs. Emma Taylor, Ms. | Orisha,
Ms. Aziza Ahmed, Ms. Isabella Burns

Navigating through the Contraction Phase of the July Uprising in
Bangladesh: Public Sociology in Context

» Mr. Md Al Ifran Hossain Mollah

Fragmenting the Fragmented: Global Sociological Implications of
Electing Authoritarian Leaders

» Dr. Abdy Javadzadeh

Contested Ecologies: Women's Environmentalism and Eco-Fascist
Resurgences in Campania, Italy

» Dr. Valeria Bonatti

Teaching Sociology Mini-Conference: Utilizing Creativity in the
Classroom |

Salon 1

Bridging Art and Analysis: Visual Pedagogies for Understanding
Health and Inequity

» Dr. Jlen McGovern, Dr. Kelly Joyce, Dr. Laura Senier, Dr. Kelly
Underman

Drawing as Pedagogy
» Dr. Raj Ghoshal
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Continued from Thursday, 5 March 2pm Feeding the West: A GIS Analysis of Food Bank Resources in
Relation to Social Disparities

» Ms. Kela Seavey, Ms. Kristi Hirayama, Prof. Alana Haynes Stein

2:26pm The Social Movements Podcast Project: Learning Through Public
Sociology 2:13pm From Good Farmer to Good Birder: Legitimacy and Inequality in
» Dr. Ashley Green Environmental Practice in the Greater Boston Area
» Ms. Lan Huang
2:39pm Pandemic for Teaching Contagion: lllustrating simple and complex
contagious spread through interactive board game play 2:26pm Environmental Justice for the Rural Middle-Class: Examining the

Energy Crisis in Cayey, Puerto Rico

» Dr. Hannah Espy
» Mr. |Jacob Rivera

2:52pm Community-Based Reearch as Senior Capstone 2:39pm Environmental Injustice, Mutual Dependence, and Perceptions of
» Dr. Kimiko Tanaka Climate Change
» Prof. Tim Bartley
2pm Military Sociology and Worldmaking Mini-Conference: War, Policy,
and Geopolitics 2:52pm Environmental Justice and Urban Highway Removal
Salon 3 » Dr. Tanesha Thomas
Chaired by: Dr. Ryan Kelty
2pm Sociology of Reproduction Mini-Conference: Contraception
2pm The Militarization of NAFTA Salon D
» Prof. Ghazah Abbasi, Ms. Alena Elkins, Ms. Liberty Hastings
2pm Reproducing Disinformation: Al Chatbots, Contraceptive

Counselling, and Sentiment on Reproduction

2:15pm The Shifting Social Foundations of Public Trust in Taiwan's Military .
» Dr. Lauryn King
» Dr. Josh Wenger
2:15pm How do gender attitudes relate to permanent contraception?:
2:30pm Objects of Strategy: Military Failure in Afghanistan OfPSrsatli\;na“Zing Masculinities using a population-based sample
of U.S. Men

» Dr. Alan Dugger .
» Ms. Sinem Esengen

2:45pm The Role of Religion, Ethnicity, and Militarism in Contemporary 2:30pm Who Is Shielded from Structural Sexism? Marriage, Health
Turkish Foreign Policy Insurance, and Women's Ability to Access Preferred Contraceptive
» Dr. Adem Ustln Catalbas Methods
» Dr. Elizabeth Anderson
2pm Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Environmental Justice 2:45pm Involuntarily Unsterilized: Necessary Changes to the Medicaid
and Inequality Sterilization Consent Process Post-Dobbs
Salon B » Prof. Deborah Machalow
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3:30pm

3:30pm

3:45pm

4pm

4:15pm

3:30pm

3:30pm

3:45pm

4pm

Structures of Constraint and Their Everyday Effects
London 1

Programming Without Permission: The Town Hall as a Tool for
Sustaining DEI Pedagogies and Practices

» Dr. Victoria Gonzalez

Connecting the Dots: Linking Structural Racism Indicators to
Federal Economic Development Intervention Programs

» Dr. Lacee Satcher, Dr. Lars Johnson

“Frugal Living"”: Coping with Poverty and (a)Political Discourse in
Online Spaces

» Dr. Meghan Kallman

Alliance for Latino Youth Mental Health and Advocacy: Lessons
Learned from an Academic-Community Partnership

» Dr. Gabriela Leon-Perez, Dr. Rosalie Corona, Dr. Lorena Suarez
Cabrera

Race, Migration, and Class (Sponsored by Committee on Status of
Ethnicity, Race, and Racism)

Salon C

Waiting to Be Discriminated Against: Haitian Immigrants,
Healthcare, and Racialized Legal Status

» Dr. Nilufer Akalin

‘Bozales' and ‘Ladinos' in the USA: How the Nursing Profession
Racializes African Immigrants

» Dr. Chinyere Osuji

No Welcome for Black Refugees. A Tale of Systemic and
Institutional Anti-Black Racism

» Dr. Bernadette Ludwig
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4:15pm

4:30pm

3:30pm

3:30pm

3:45pm

4pm

4:15pm

3:30pm

3:30pm

3:30pm

Both Asset and Burden: Race, Identity, and Professional Strategy
Among Black Public Defenders

» Ms. Tashawn Reagon

Why Did Du Bois Oppose Reparations?
» Prof. Tyler Leeds

Decolonizing Projects, Struggle and Transformation
Salon E

Decolonizing The Settler City: Native Knowledge, Sociology, and
the Making of Cooperative Projects in Lenapehoking (New York
City)

» Dr. Jacob Boersema, Ms. Sujung Woo, Ms. Alex Ledesma

Reclaiming Space: the Sogorea Te' Land Trust and the struggle for
identity through urban placemaking

» Dr. Mario Hernandez, Dr. Natalee Kehaulani Bauer

Transferring Identity: Out-of-State Incarceration and Native
Hawaiian Subjectivities

» Dr. LeShae Henderson

Decolonizing Feminisms: The Geopolitics of Knowledge Production
in a Transnational Collaborative Oral History Project

» Dr. Jayati Lal

Panel: Understanding Immigration to the DMV After the COVID-19
Pandemic

Penn Quarter

Understanding Immigration to the DMV After the COVID-19
Pandemic

» Mx. Tabby Ford, Ms. Amanda Vincent, Ms. Caryalyn |ean, Ms. Anjini
Patel

Creating Community (Sponsored by Committee on Status of
Ethnicity, Race, and Racism)

London 2
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3:30pm

3:45pm

4pm

4:15pm

3:30pm

3:30pm

3:43pm

3:56pm

4:09pm

Genetic Ancestry Testing and Conceptualizations of Race and
Ethnicity Among Young Adults

» Dr. Whitney Hunt, Dr. David Merolla

“They've taken prayer out of public school...”: How White Parents
in Mississippi Make Sense of Maintaining Segregated Schooling

» Dr. Courtney Heath

Sacred Continuities: Religion, Ethnic Belonging, and
Intergenerational Identity in Greek Orthodox Immigrant
Communities

» Ms. Fotini Karabinas

Comparative Racial Consciousness among Chinese Youth on
Temporary Visas: Rethinking Racialization Beyond Borders

» Ms. Qing Tingting Liu

Communities in Contention Mini-Conference: Civic Engagement,
Activism, & Community Organizations

Salon 2

Not in my school district: motherhood as a political resource for
activism

» Mrs. Dilia Zwart

Fractured Communities: How Civic Leaders Politicize and Divide
» Mr. Benjamin Bolawa, Dr. Meaghan Stiman

How affinity groups become integrative: Examining the interplay
of community and contention in organizational life

» Dr. Krystal Laryea

Constructing Meaning in Campus Protest Coverage: Role
Conceptions and Framing in Student Journalism

» Ms. Rebekah Lazar
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4:22pm

3:30pm

3:30pm

3:41pm

3:52pm

4:03pm

4:14pm

4:25pm

3:30pm

3:30pm

Unruly care: Organizational tensions in addressing migrant and
community needs

» Dr. Alejandro Marquez

Teaching Sociology Mini-Conference: Utilizing Creativity in the
Classroom Il

Salon 1

Making Individualism Transparent
» Dr. Carla Corroto

Shopping for Stereotypes and Paying the Price: A Lesson on the
Social Construction of Gender

» Mx. Sarah Bowker

Teaching about status
» Dr. Christianne Corbett Corbett

Structure of Studenthood: Building Experiential Learning Through
Case Studies

» Prof. El Néel

Empowering Critical Policy Analysis: Teaching Social Inequality
Through Real-Time Policy Evaluation

» Dr. Marya Mtshali

Teaching Intrinsic Motivation in a time of Artificial Intelligence:
Can Mindfulness Help?

» Dr. Aarushi Bhandari, Dr. Kevin McElrath, Mr. Uday Ahuja

Military Sociology and Worldmaking Mini-Conference: Norms, War
and Inculcated Values

Salon 3
Chaired by: Morten Ender

Uniformed Bodies: Unstandard Standardization at West Point
Prep

» Dr. Taylor Winfield
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Continued from Thursday, 5 March 3:30pm Sociology of Reproduction Mini-Conference: Chronic Iliness
Salon D

3:45pm E:;v&;ssﬁ?;demy Cadets’ Perception of Character Attributes to 3:30pm Disabled and Chronically Ill Parenthood: Defining Concerns and

Resiliencies

» Dr. Katie Matthew, Mrs. Allie Ronske, Dr. Karin DeAngelis, Dr. Ryan » Ms. Morgan Rosellini

Kelty, Dr. Michael Matthews

3:43pm The Social Life of Polycystic Ovary Syndrome (PCOS)
4pm Opening the Black Box of War Studies: Critique of Junior Officers » Ms. Dunahay Pereyra
training during Russia’s War on Ukraine
» Dr. Karl Yden 3:56pm Gendered Responsibility for Fetal Outcomes Among Couples
Experiencing High-Risk Pregnancy
3:30pm Environmental Sociology: Transformation and Repair in » Dr. Anna Church
Constraining Environments Mini-Conference: Floods, Fires, and
Disaster Adaptation 4:09pm Endometriosis and Disability: A Critical Narrative Review
Salon B » Ms. Colleen Kavanagh
3:30pm After Fire, Where Is Home? 4:22pm The Biopolitics of “Previving”: Femininity, Disability, and
» Dr. Haisu Huang Reproduction
» Ms. Teodora Brnovic, Dr. Alyson K. Spurgas
3:45pm What the Fire Couldn’t Take: Gendered Recovery and Resilience in . . . . .
P Lahaina, Hawai'i After the 2023 Wildfire y 5pm Presidential Plenary: Repair as Worldmaking: Black Reparations and
Closing the Racial Wealth Gap
» Ms. Lauren Taylor
Salon 2
4pm Counter-cartographies of Urban F|00ding: Narrative, Memory and 5pm Military s°ci°|°gy Mini-Conference Reception

Risk in Waltham, MA

» Dr. Rachel McKane, Ms. Danielle Jacques, Dr. Sarah Mayorga, Dr. Sara
Shostak

4:15pm Choosing Grey, Green, or Hybrid? Evaluating State-led Urban Flood
Adaptation Strategies in Massachusetts, USA

8am igi
» Mr. Spandan Pande Technoculture & Digital Space
Salon B
4:30pm Basement Flooding in New York City: Complexities, Unequal 8am Towards a Critical Technocultural Reflexivity: Thinking through
Harms, and Recommendations for Residents, Communities, and ethnography as a method for the sociological study of digital
Local Government communities
» Prof. Gregory Smithsimon, Mr. Tenn Joe Lim » Dr. Kevin Winstead

Powered by Ex Ordo, everything you need to run a research conference. Page 16


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Friday, 6 March

8:13am

8:26am

8:39am

8:52am

8am

8am

8:15am

8:30am

8am

Watching the Watchers: Initial Findings of a Digital Participant
Observation of Twitch Livestreaming Communities

» Mr. lack Leatherman

Unsung: Poetry, Emotional Labor, and Digital Spaces of
Counterpublic Formation

» Ms. Yee Lok Won

Synthetic Souls: Generative Al and the Theft of Intellectual
Property in Digital Spaces

» Ms. Chaprill Bostick

From Hashtags to Harassment: Cyberviolence in Environmental
Justice Movements

» Dr. Robert Cavazos, Dr. Roderick Graham

Gender Contexts & Gender Outcomes
London 2

Perception, Performance, and Occupational Segregation: How
Gender Identity and Gendered Perceptions Shape Income
Inequality

» Dr. Shannon N. Davis, Ms. Alyssa Cazier, Ms. Wonmai Punksungka,
Dr. Kellie Sue Wilkerson

Mothering Through Isolation: A Qualitative Study of Pregnancy
and Parenting During the COVID-19 Pandemic

» Mrs. Rose Anderson

The relationship between gender and generation and perceptions
of depression; results from the 2024 General Social Survey

» Ms. Amanda Miccolis

Punishment & Control
Salon C
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8am

8:15am

8:30am

8:45am

8am

8am

8:15am

8:30am

8:45am

8am

‘Agents of Change:’ Bureaucrats’ Beliefs at the Junction of Welfare
and Punishment

» Dr. Catherine Sirois

The Courtroom as Theater but not Play: The Effects of Defendant
Presentations on Court Proceedings

» Ms. Kaley Whipkey

Constructing Supplicants: The Role of Normative Controls in
Authoritarian Responsiveness

» Dr. Fengrui Tian

“They Get Everything”: Nativist Boundary Work and the Politics of
Deservingness Among Welfare Recipients

» Dr. Melissa MacDonald

Racial Formations and Racialization
London 1

SKIN COLOR AND EDUCATIONAL INEQUALITY AMONG BLACK
INDIVIDUALS OF THE ANGLOPHONE CARIBBEAN

» Dr. Monigue D. A. Kelly

Transnational Campus Spaces: Indo-Guyanese Students Using
Campus Life to Mark Ethnic Boundaries

» Dr. Nazreen Bacchus

The brick and mortar of colonial ideology: the case of France’s
“Colonial School” and its legacy.

» Dr. Marie Leonard

Race as Both a Exclusion and Inclusion: How Sociology Needs to
Reconceive How Racism Operates

» Dr. Pawan Dhingra

Ethnographic Practice
Penn Quarter
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8am

8:15am

8:30am

8:45am

8am

8am

8:13am

8:26am

8:39am

8:52am

Managing in the Field: Doing Ethnography as a Boss
» Prof. Ben Shestakofsky

The Helpful Ethnographer
» Prof. David Trouille

Reflections on Twenty-Five Years of Doing Autoethnography
» Dr. Todd Schoepflin

Revisiting Empathy: Use of Emotions in Ethnography within
Problem-Oriented Sociological Work

» Ms. Pei-Chen Cheng

Education (Sponsored by Committee on Status of Ethnicity, Race,
and Racism)

Salon D

Equalizer No More: Intersections of Chinese, Black, and Choctaw
Education in The Age of Separate and Unequal Policies

» Ms. Mia Xia

Page Not Found: How Equity-Focused Districts Adapt to Federal
Constraints

» Dr. Jonathon Acosta, Dr. John Diamond

Higher Education Exposed: Meritocracy as a Smokescreen for
Racial Capitalism and AntiBlackness

» Dr. Bedelia Richards, Dr. Amanda Frye

No Silver Spoons: Analyzing Student Hunger in Private Schools
» Ms. Ambria Jones

‘Controversial’ Content in Public Schools: The Intersection of
Federal, State and Local Policies in the Shadow of the Capital

» Dr. Linda Waldron, Dr. Jane Rochmes
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8am

8am

8:15am

8:30am

8:45am

8am

8am

8:15am

8:30am

Military Sociology and Worldmaking Mini-Conference: Resilience,
Wellbeing, and Readiness

Salon 3
Chaired by: Dr. Katie Matthew

Exploring the future landscape of military mental health: A
scenario planning approach

» Ms. Linda Slapakova

From Soldier to Trainer: The Dynamics of Former Military
Personnel as Contractors in Partner Nation Capacity Building

» Dr. Whitney Grespin

The changing ‘ask’ and risk of military life: Perspectives on ‘Risks
that Matter’ from Royal Air Force and Royal Navy personnel

» Ms. Linda Slapakova, Ms. Catherine Galley, Dr. Tristan Kreetz, Mr.
Sean Flanagan

Leveraging Communication for Resilient Outcomes in the Military:
Fostering Repair, Reintegration and Transformation

» Dr. Susan Steen, Dr. Lauren Mackenzie

The Critical Sociology of Death Mini-Conference: Grief and
Grievability

Salon E

Stigmatized Grief - Understanding co-victims grieving experiences
after gang-related homicide

» Ms. Samt Selman

“That’s my tribute to him”: The Relationality and
Disenfranchisement of Black Grief After Police Violence

» Dr. Nora Gross, Mr. Betselot Wondimu, Ms. Uzma Chowdhury, Mr.

oseph Sanchez

Mediating Death: Immigrant Bereavement as a Brokered Process
» Mr. |ulio Fernando Salas
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8:45am

8am

8am

8:15am

8:30am

8:45am

8am

8am

Beyond “a Journey of the Spirit”: Rethinking Personalized Dying in
Hospice
» Dr. Deborah Streahle

Transforming and Repairing Health Professions Education Mini-

Conference: Enduring Challenges within the Health Professions Field

Salon 1

Racial Gaslighting in Medical Education
» Dr. Kelly Underman, Dr. Lauren Olsen

Navigating Medicine with Disability: Professional Identity x
Professional Ableism

» Mx. Grace Franklyn

Taking the Pulse on Medical School Leaders’ Responses to the
Dismantling of Abortion Care

» Dr. Lauren Olsen, Ms. Siyona Keya

An Intersectional Census of 16 High-Impact Medical Journals by
Skin Tone, Race, Ethnicity and Gender From 2000-2022

» Dr. michael mensah, Dr. Dalia Owda, Dr. Sydney Axson, Dr. Michele
Buonora, Ms. Priya Dahiya, Ms. Lauren Hagani, Dr. Hazar Khidir, Dr.
Angela Kyei, Dr. Jenna Lester, Dr. Fabiola Molina, Prof. Rourke O'Brien,
Dr. Christina Mangurian, Prof. Phillip Solomon

Bringing the People Back In Mini-Conference: People-ing Protest
Salon 2

Reckoning, Repair, and Transformation: How Grassroots Memory
Work Reshapes Political Communities

» Dr. Hajar Yazdiha
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8:15am

8:30am

8:45am

8am

Exit, Voice, and the Purple Line: Sustaining Civic Power in the Age
of Mass Protest

» Prof. Elizabeth McKenna

Forging the New Unionism: Labor Rights, Worker Insurgency, and
the Growth of Public-Sector Labor Movements in the 1960s

» Mr. Joseph van der Naald

Shifting Coalitions, Changing Claims: The Role of Clergy in the
Black Movement, 1994-2010

» Ms. Anna Milewski, Dr. Chaeyoon Lim, Dr. Pamela Oliver

Undergraduate Student Posters, Session |

Gender Data Collective: An Interdisciplinary, Collaborative Study
on Regional-Based Sex Education and Gender Attitudes in the U.S.

» Ms. Seren Julian, Ms. Ella Kushins, Ms. Lucy Eckel, Ms. Nora Perez-
Rubio, Ms. Liliana Triviski, Ms. Natalie Lauchlan

An Analysis of Gun Death Rates in U.S. States: Exploring the
Impact of Background Checks, Assault Weapons Bans, and Mental
Healthcare Expenditure

» Mx. Garrett Washington

High Expectations: Exploring the Link between Age, Health, and
Attitudes about Marijuana Legalization in the United States

» Ms. sadie steinberg

Moral Judgements in Modern HIV Stigma: A Quantitative Analysis
of Political Ideology, Religion, and HIV Attitudes

» Ms. Zoe Moga

Religiosity and Carceral Logic: How Christian Ideology Influences
Attitudes on Crime in the US

» Ms. Rachel Traband

Obstacles for Seeking Help for Sexual Assault in the Latinx
Community

» Ms. Gwen Dorsey, Dr. Amanda Konradi
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Prejudice, Isolation, and Technology Use: The Impacts of Social
Media on Student Prejudice Against Diverse Contacts at Loyola
University Maryland

» Ms. Janet Gosnell, Dr. H. Lovell Smith

The Myth of Feminized Education: How Men's Rights Activists
Reframe Academic Decline

» Ms. Lauren McNally, Dr. Stephanie Ortiz

Quantifying State Sexual Education Quality to Model Teen Birth
Outcomes

» Mr. Jude Poirier

The Impact of Detention on Immigrant Children's Mental Health
» Prof. Ghazah Abbasi, Ms. Liberty Hastings, Ms. Alena Elkins

"One hand could never clap:" Blackness as a Tool for Political and
Multiracial Solidarity in Trinidad & Tobago

» Mr. Anand Ginsburg-Shukla

The Endurance of Anti-Haitian Rhetoric: How Racial Politics
Became Embedded in Dominican National Identity

» Ms. Anne Vasquez

Analyzing Media Narratives: How Fox News Influences Public
Opinion of Abortion After Dobbs v. Jackson

» Ms. Erin Bothe, Dr. Daniel Farr

Erasing the Spectrum: Intersectional Exclusions of Autism in
Television

» Mx. Jay Mario Bates Domenech

Recommendations For Promoting A More Integrated And Soul-
Enrichening Experience For The LGBTQ+ Community

» Ms. Mariana Mulhern
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9:30am

9:30am

9:45am

10am

10:15am

9:30am

Stay Off Our TERF: Predictors of Anti-Trans Feminists Opposition
to Trans Girls in K-12 Sports

» Dr. Amanda Hernandez, Mr. Aris Morgan, Ms. Greta Nelson

The Perception of the West Under Threat: American Attitudes on
China

» Mr. Aris Morgan

Liberate Hong Kong: Nationalist Secession and the Localist
Movement

» Mr. lvan Wong

Students of Colonialism in the French Resistance: The Dissonance
Between The Colonial Project and Resisting Nazi Oppression

» Ms. Marisol Hoffmann

Neighborhoods & Gentrification
London 1

JEWISH ASSIMILATION IN CHICAGO SOCIOLOGY: "THE GHETTO" AT
ONE HUNDRED

» Dr. Nicolas Eilbaum

What is the time of gentrification?
» Prof. Johanna Bockman

The Mercer County NJ Ethnoburb
» Dr. Diane Bates

Power Built on a Dream: KC Tenants and the Revolutionary Fight
for Housing Justice

» Dr. Michelle Smirnova

Boundary Making (Sponsored by Committee on Status of Ethnicity,
Race, and Racism)

London 2
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9:30am

9:43am

9:56am

10:09am

9:30am

9:30am

9:30am

9:30am

“We Must Retain the Character of Our Neighborhoods": A Rural
Community Response to a Racial Demographic Shift

» Dr. Betty McCall

Anti-Blackness in Cyber Spaces: Applications of Machine Vision in
Studies of Race and Racism

» Prof. Demetrios Lambropoulos, Dr. Xuemeng Li, Ms. Yeyang Chen,
Dr. Jessica Hardie

Beyond Homophily: Fields and Boundaries in the Maintenance of
Cross-Racial Ties

» Dr. Jiajia Wei

“Suspicious Person Posts and Racial Profiling Anxiety in
Neighborhoods”

» Dr. Maria Lowe, Ms. Claire Adams

AMC: Japonica Brown-Saracino, The Death and Life of Gentrification:
A New Map of a Persistent Idea

Salon C

AMC: The Death and Life of Gentrification: A New Map of a
Persistent Idea by Japonica Brown-Saracino

» Dr. |effrey Parker, Dr. Japonica Brown-Saracino, Dr. Derek Hyra, Dr.
Yuki Kato, Dr. Sarah Mayorga

Military Sociology and Worldmaking Mini-Conference: Influence
Across Social Institutions

Salon 3
Chaired by: Mrs. Allie Ronske

Navigating Military Life: The Impact of Singlehood on Workplace
Experiences and Well-being

» Ms. Samantha DeCapua
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9:45am

10am

10:15am

9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

Uniform Appeal?: U.S. Perceptions of Military Veterans as More
Qualified Political Candidates

» Prof. leremy Teigen

The Leadership Power Grid: A tool for teaching
» Dr. Christopher Kelley

The Few, the Proud: Non-Citizens in the U.S. Military, A Historical-
Sociological Perspective

» Dr. Guido Rossi

The Critical Sociology of Death Mini-Conference: Boundaries,
Borders and Bodies

Salon E

Patriarchal Coloniality & Femicide in Mexico
» Prof. Ghazah Abbasi, Ms. Alena Elkins, Ms. Liberty Hastings

The Social Construction of Death: A Case Study of the Partition of
India and Pakistan

» Ms. Sophia Bertsch

Political Death and Subjectivity in Kurdish Society
» Ms. Derya Aydin

On the Boundaries of Violence: Mapping the Spatial Correlation
between Homeless Deaths and Encampment Sweeps in Seattle,
WA 2008-2024

» Ms. Kennedy Patterson

Transforming and Repairing Health Professions Education Mini-
Conference: Organizational and Epistemic Transformations in
Health Professions Education

Salon 1
How the How the Quadruple Aim May be at Odds with the Triple
Aim

» Dr. Tania Jenkins
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9:45am

10am

10:15am

9:30am

9:30am

9:45am

10am

10:15am

The Medicalization of Loneliness: Addressing Social Ills through
Healthcare

» Ms. Sofia Hiltner

Disparities in Mental Health Language in Clinical Notes: An
Original Video Vignette Survey Experiment

» Ms. Fatima Fairfax

Yesterday, a janitor. Today, a surgeon. How healthcare
professionals’ transnational mobility disrupts status hierarchies

» Mr. Derek Richardson

Bringing the People Back In Mini-Conference: Political Attitudes and
Perceptions

Salon 2

The Mirage of Democracy: How the Political Process Nurtures
Disillusionment and Distrust

» Dr. Sadie Dempsey

Hindutva and Hinduphobia: Transnational authoritarianism,
racialized youth mobilization and nationalist politics of the Indian
diaspora in the US

» Ms. Debadatta Chakraborty

Intensify/Enhance: How GenZ Perceives Social Media, Cohesion,
and Politics in Tumult

» Mr. Aaron Thompson

What's the Matter with Cambridge? The Cultural Roots of Far-
Right Success

» Prof. Joan Williams
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9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

9:43am

9:56am

Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Political Ecologies in
the Global South

Salon B

Lithium mining in Argentina: a multi-scalar study of socio-
cultural, economic, and political dimensions of extractive
capitalism and local realities.

» Ms. Emilia Ravetta

Human and Nonhuman Actors at the Ocean Frontier: Fishmeal
Production and the Unmaking of The Gambia

» Mrs. Fatou.H. Jobe

Predatory Growth Machine: The Political Economy of Resource
Frontiers

» Dr. Gabriel Suchodolski

The Role of Tribal Faith in Forest Conservation and Wildfire
Prevention in India: An Exploration of the Lived Experiences of the
Sarna Religious Tribal Community

» Mr. Mohd Amin Khan

Sociology of Reproduction Mini-Conference: Reproductive
Governance |

Salon D

Maternal Risk Governance: Child Welfare and Reproductive
Regulation

» Dr. Matty Lichtenstein

Punishing Private Grief: Analyzing the Criminalization of
Pregnancy Outcomes Under Laws Meant to Address the
Disposition of Human Remains

» Ms. Laura Huss, Ms. Farah Diaz-Tello
Fetal Prioritization and the Policing of Motherhood: Treatment

Pathways of Pregnant Women with Opioid Use Disorder
» Ms. Kaylee Garcia
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10:09am

10:22am

9:30am

9:30am

"The Nation's Vitality": Eugenics Discourse in The Washington
Post, 1906-2025

» Mx. Han Koehle

Cryopreserving the "Good wife, wise mother"? The political
economy of egg freezing in Japan

» Dr. Anna Wozny

DC' 2026 Institute on Teaching Social Action
Salon A

Undergraduate Student Posters: Session Il

Rethinking Informed Consent for Equitable Healthcare Access

» Ms. Jennifer Mckenzie

Connecting the Disconnect: Explaining the Ideological
Inconsistency in the Voting Behavior of Korean American
Immigrants

» Mr. John Kim

Balancing Class and Competition: Black Middle-Class Collegiate
Athletes’ Experiences

» Dr. Kris Marsh, Ms. Maya St. Hillaire, Ms. Madison McGowan, Ms.
Demi Fragoyannis, Ms. Lori Nambo, Mr. Michael Harris

Female Athletes Level of Support at HWI's & HBCU's

» Dr. Kris Marsh, Ms. Hannah Balcanoff, Ms. Sophia Thompson, Ms.
Emma Khafif, Ms. Kori Edmondson

Power in the Stands: Inequality in Global Fan Cultures

» Dr. Kris Marsh, Ms. Vivian Miller, Ms. Judy Nasser, Ms. Alexa Salazar,
Ms. Pragya Goel, Ms. Abigail Katz
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Public Perceptions of How Socioeconomic Status Shapes Health
Outcomes in Black Communities

» Dr. Kris Marsh, Ms. Ella O'Neall, Ms. Leen Osman, Mr. Aaron Wilson,
Ms. Alyssa ShenFilerman, Ms. Destini Stafford

How Foreigners view Filipinos in marriages
» Ms. Felomina Antolin

Media Representation of Liberia Women
» Ms. Sema M. Williams

Religion, Education, and Exclusion: An Analysis of School
Chaplaincy Programs as Exclusionary Social Institutions

» Ms. Lineth Garcia

Spatial Narratives: Women'’s Roles, Agency, and the Evolving
Concept of Womanhood in Contemporary Morocco

» Ms. jazmine sanchez

Student or Suspect? The Dual Consciousness of Race and
Authority at Gettysburg College

» Ms. Lineth Garcia

Working Through College-Effects of Burnout
» Mr. Elijah Powell

The Reality of International Research Ethics Policies in a Post-
COVID World

» Ms. Madeline DeVito, Dr. Marthinus Koen, Ms. Abigail Hall

Performative Labels under Censorship: T/P/H Gender Culture and
Lesbian Identity in Digital China

» Ms. Elaine Yang

Gambling with Gentrification: Casino Urbanism on Neighborhood
Identity

» Ms. Monica Claros
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10:45am

T1am

T1am

11:15am

11:30am

The Legacy of Redlining: Investigating Impacts on Modern Crime
» Ms. Camille Fei, Ms. Natalie Harkins

Between Tradition and Modernity: Religious Identity and Practice
Among Indian American Women in the Same Family

» Ms. Ananya Patel

Public Grief and Moral Judgment: Online Reactions to a Case of
Vicarious Violence in Uruguay

» Ms. Sofia Leyba

Does Health Literacy Influence Vaccine Hesitancy? The Role of
Education, Religion, and Political Ideology

» Ms. Ruthanne Troutman, Ms. Anna Kerns

Physical and Social Oral Health in Relation to Depression
» Ms. Melanie Villarreal, Ms. Jana Elarousy

Refreshment Break

Knowledge Claims, Trust, and Scientific Authority
London 1

Epistemic Hierarchies in Medicine and the Struggle for Credibility

» Ms. Jayla Gray-Thomas

Once upon a Lyme: How scientists respond to public distrust and
misinformation

» Mr. Robert "Max" Freedman, Dr. Catherine Tan

Proof of a Conspiracy? An Analysis of Evidence and Arguments in
American Conspiracy Theories

» Prof. Tony Feldmann
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11:45am

11am

T1am

11:15am

11:30am

11:45am

11am

T1am

11:15am

11:30am

Sociogenomics of Sociogenomics: Toward a Queer and Feminist
Epistemology

» Mr. Eralp Karduz

Race, Community, and Place
London 2

Mexican-Looking Driver Traffic Stops in Upstate New York:
llluminating Racialized Hierarchies in Policing through
Counterfactual Proxy Case Analysis.

» Dr. Robert Smith

Under Watch: Migrant Visibility, Legal Consciousness, and the
Everyday Politics of the New York City Subway

» Manjeet Kaur

"Danger to the Community": Bond Hearings and the Racialized
Politics of Safety

» Mx. Teagan Murphy

Funeral finance from beyond the family: The case of community-
initiated memorial crowdfunding

» Ms. Cat Ton

Politics (Sponsored by Committee on Status of Ethnicity, Race, and
Racism)

Salon C

Defensive Whiteness in Practice: MAGA Voting, Historical
Backlash, and Economic Self-Sabotage

» Ms. ESSENCE WYNTER

"I'm Not Political, But...": Storytelling, Silence, and Narrating
Whiteness

» Ms. Amelia Paterno
A Posh Avenue, a Downtown Mall, and the Racial and Political

Imaginaries of Urban Development
» Dr. Sarah Ochs
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Continued from Friday, 6 March 11:45am Deploying Taboo, Managing Death: Moral Economies of the
Funeral Industry in Contemporary China

» Ms. Xinling Zhou

11:45am Anti-Tutsi Ideology, Its Historical and Chosen Passion
» Ms. lessica Mwiza T1am Transforming and Repairing Health Professions Education Mini-
Conference: Shaping Future Health Professions In and Beyond the
T1am Military Sociology and Worldmaking Mini-Conference: Women, War, Classroom
and Belonging Salon 1
Salon 3
Chaired by: Mr. Sunil Misra 11am Not Just for Doctors: The Importance of Social Sciences &
Humanities in Physician Assistant Education
T1am Playful Femininity: Rethinking Military Professionalism among » Prof. Michelle Gotto, Prof. Sara Kraus
Women Field Observers in the Israel Defense Forces
» Dr. Nehemia Stern 11:15am Scholarly Engagement and Collaboration: A Case Study of OBGYN
Clerkship Education
Mr. Emerson Woody, Dr. Jenny Melli, Dr. Britt Dahlber
11:15am Attitudes Toward Women in Combat and Service Roles: A 7 = Jenny &
Comparative Analysis by Respondent Gender
» Ms. Kylie Wray, Ms. |ulia Tierney, Dr. Ryan Kelty 11:30am “¢Me entiendes?” An exploratory characterization of
translanguaging in medical Spanish training encounters
» Mx. Maya Osman-Krinsky, Dr. Pilar Ortega, Dr. JL Prada, Dr. Lisa
11:30am Militarized Institutionalization: Centering Women Military Diamond, Dr. Reniell Ifiiguez
Member Experiences
» Ms. April Koeberle 11:45am To Pivot or Reapply: How social class shapes decisions of rejected
medical school applicants
1T1am The Critical Sociology of Death Mini-Conference: Ritualizing the » Mr. Philip Barrison, Dr. Alexandra Vinson
Dead
Salon E 11am Bringing the People Back In Mini-Conference: Racial Politics
Salon 2
11am Postmortem Ties in China
» Dr. Becky Hsu 11am The Racial Registration Gap: Examining the impact of site-based
voter registration tactics on countering racial and ethnic
. . . inequality
11:15am Death ritual as political theatre

» Dr. Nathalie Rita, Ms. Colleen Heidorn

» Prof. Vrinda Marwah

11:15am The 2024 Presidential Election & The Politics of Race: Racial

11:30am Governing the Unclaimed Dead: Welfare State, Familial Rhetoric, Racial Selfhood, and Racialized Emotions at the
Recognition, and the Legal Structure of Death in South Korea Intersection of Political Identification in the Contemporary U.S.
» Ms. EUNSOO CHOE » Prof. Enid Logan
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11:30am

11:45am

T1am

T1am

11:13am

11:26am

11:39am

11:52am

T1am

Sites of Power: Barriers and Boundaries in Racial Politics
» Dr. Michael Rosino

Democratic Mayors and Black Churches
» Dr. Chloe Ricks

Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Carceral Logics and
Environmental Racism

Salon B

Set Ablaze: Incarcerated Women as Firefighters on the Frontlines
of the Climate Crisis

» Ms. Raquel Delerme

Carceral Wastelanding: Carceral Logics of Sacrifice in California
Prison Siting

» Mr. Anthony Landers Michel

Tearing down the silos: Transdisciplinarity and experiential
expertise in tackling convergent environmental, public health,
and carceral crises

» Ms. Liz Corrado, Dr. Dave Ciplet

Inequities in Rates of Asthma Because of Environmental Racism
in the South Bronx

» Dr. Janet Michello

Contaminated Waters: How Social Demographics Can Be
Predictors of Heavy Metals in Community Water Systems

» Ms. Polina Kopeikin

Sociology of Reproduction Mini-Conference: Reproductive
Governance Il

Salon D
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T1am

11:15am

11:30am

11:45am

11am

‘Pregnancy as a weapon': Constrained contraceptive access
among Haredi Jews and religious dimensions of reproductive
governance and coercion

» Ms. Alicia |en, Ms. Gloria Fortuna, Dr. Jessie Ford, Ms. Fraidy Reiss, Dr.
Jennifer Hirsch

Preparing Female Bodies for More: Soft Governance of
Reproduction in China’s Transitioning Reproductive Policies

» Dr. Siyi Huang, Mr. Yingyu Zang

What Are We Really Worried About? Media Framing of Falling
Birthrates

» Dr. Carrie Smith

Hormonal Kin Making: Transgender Reproduction, State Power,
and the Right to Ambivalence

» Mx. Carlo Sariego

Undergraduate Student Posters: Session 11

Homeownership as a Social Determinant of Health: Exploring the
Impact of Homeownership and Neighborhood Environment on
Health

» Dr. Sharron Wang, Ms. |oselyn Reyes Alvarez

The Impacts of Dental Education on Oral Health and Hygiene of
Special Needs Individuals

» Ms. Bhavini Shah

Examining elite college students' perspectives on their parents’
parenting styles

» Ms. Katherine Wu, Dr. Ya Su

Narrations of Orthodoxy and Loss in Post-Imperial Ethiopia
» Ms. Lena Habtu

Podcasts, Immigration, and 2024 US Presidential Election
» Mr. Reishiro Kawakami

Page 26


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Friday, 6 March

Time's Up: Examining How Time and the Patient-Provider
Relationship are Shaped in Pediatrics

» Ms. Doris Serrano

Transforming Wood, Transforming Bodies: Addiction Recovery at
an Appalachian Guitar Shop

» Ms. Eva Murillo

Unbroken Circles: Restoring Young Lives
» Mr. lJamari Porter

Assessing the Effectiveness of Gun Violence Intervention
Programs

» Mr. Zion Matthews

"Our People Ain't Crazy": Race Stigmatization and Buidling
Supportive Mental Health Communities Online

» Ms. Alexandria Stephens Prisock

(Giving) Sexy Back; Relational and Reflexive Body Image in
LGBTQ+ Populations

» Ms. Ju Derraik

Cultural Competence in Practice: Social Worker’s Role in Assisting
Caribbeans in Massachusetts

» Ms. Micaela Henry

Exploring the Advocacy Coalition Framework of Transportation
Advocates in Boston, MA

» Mr. Gerard Zhou

From Abstinence to Algorithm: Individual Differences in Assessing
Sexual Health Information on TikTok

» Ms. Ella Wagner
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12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

Generations Apart: The Impact of Puerto Rican Residency in the
United States on Identity and Perceptions of Latinidad

» Ms. Abigail Rosario

Immigration Policy Uncertainty and the Structural Vulnerabilities
of Mixed-Status Families in Texas Border Communities

» Mx. Ammy Garcia

Impact of State Medicaid Policies on Health Disparities Across
Income Groups

» Mr. Kennedy Cargo

Creativity in the Age of Metrics: Fanwork creators’ labor,
autonomy and sense of self

» Ms. Tingyu Wang

Activism (Sponsored by Committee on Status of Ethnicity, Race, and
Racism)

London 1

“It Is Our Duty to Fight for our Freedom”: The Double-Edged Sword
of Collective Memory and Legacies of Political Exclusion on
Contemporary Activism

» Dr. Sadie Dempsey

Sociology in Turmoil: Why Wellbeing is Critical in an Anti-DEI Era
» Dr. Giselle Greenidge, Ms. Amaya Woods

1968 to 2016: A Comparative Analysis of the Historical Context
and Media Response Surrounding Athlete Protest

» Mx. |ess Moskowitz

Between Empire and Academia in an Anti-DEI Era: A Critique from
the Global South

» Mr. Adil Zahoor

Al in Publishing and Pedagogy: A Panel Discussion Organized and
Moderated by Sociological Forum

London 1
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12:30pm

12:30pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

AMC: Gardens of Hope: Cultivating Food and the Future in a Post-
Disaster City. By Yuki Kato

Salon C

Gardens of Hope: Cultivating Food and the Future in a Post-
Disaster City

» Prof. Richard Ocejo (critic), Prof. Sofya Aptekar, Prof. Albert Fu, Prof.
Justine Lindemann

The Critical Sociology of Death: The Many Lives of Loss
Salon E

Death Positivity, White Respectability: A Critical History of Cicely
Saunders and the Hospice Model of Care

» Dr. Ara Francis

Language Loss and Return in the Cambodian Diaspora: A
Sociological Memoir

» Dr. Freeden Blume Oeur

Death at the Border: Traces of Central American Migrant Trans
Women's Lives

» Dr. Salvador Vidal-Ortiz

Sovereignty of the Dead: Mourning Practices in Jeju as Decolonial
Politics against South Korean Subimperialism

» Dr. Veda Hyunjin Kim

Transforming and Repairing Health Professions Education Mini-
Conference: Business Meeting and Networking Lunch

Salon 1

Bringing the People Back In Mini-Conference: Lunch Break
Salon 2
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12:30pm

12:30pm

12:43pm

12:56pm

1:09pm

1:22pm

12:30pm

12:30pm

12:30pm

Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Spatially Uneven
Development

Salon B

Nature’s Downtown: Regional Landscape Revalorization and Small
City Growth in the Rustbelt

» Dr. Ervin Kosta, Mr. Jonas Adams

Solar for Whom? Interrogating the Socio-Spatial Dimensions of
Solar Development in the United States

» Ms. Danielle Jacques

Solving the City: Imagining the Rural in U.S. Urban Climate
Mitigation Planning

» Dr. Amanda McMillan Lequieu

Rural Resistance to Renewable Energy Infrastructure: The
Influence and Limits of Partisan Politics

» Dr. Claudine Pied

Title: Co-production and Strengthening Capacity for Resilience in
Small Communities

» Dr. Emily Eisenhauer

Sociology of Reproduction Mini-Conference: Lunch Break
Salon D

Decolonial Sociology in Times of Resistance Mini-
Conference:Decolonial Approaches to Methods: Data, Positionality,
Knowledge Production

Salon 3

From Reflexivity to Respect: Decolonizing Knowledge through the
Bookseller Controversy

» Dr. Syeda Quratulain Masood
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12:45pm

Tpm

1:15pm

12:30pm

Beyond Extraction and Solidarity: Decolonizing Sociology through
Transoceanic Relationalities

» Prof. Manjusha Nair

Reimagining the Social Life of Data: Repair, Power, and Disability-
Inclusive Development

» Ms. ayesha khurshid

Beyond Eurocentrism: Reimagining Sociology in India through
Indigenous Frameworks

» Ms. Monika Monika

Undergraduate Student Posters: Session IV

Pressing Perceptions
» Ms. Kelly Kujawa

Constructing Paradise: Western Gay Men's Travel to Asia
» Mr. Travis Taylor

Capitalizing on Higher Education: How Neoliberal Capitalist
Values Shape Students Lives and Learning

» Ms. Olivia Manfrey

A Comparative study of the revenue and income of American Zen
and Christian organizations

» Ms. Samantha Saliola

Deal or No Deal? A Study of Plea Deals in Hot Car Death
Prosecutions

» Ms. Rachel Shuster, Ms. Chloe Burke

Examining Perceptions of Overweight Individuals among those
who have Struggled with their Weight

» Ms. Rachel Shuster
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1:45pm

Making it Work: Support Systems Among Latina Immigrant
Mothers in the Service Sector

» Ms. Evette Rivera

Police Officer Perceptions of Body Worn Cameras

» Ms. Sara Blackmire, Ms. Joyce Hanna

Using LLMs to Simplify Cyber Security Information
» Mr. Ryan Wojciechowski, Dr. Prerit Datta

“Football Is the Last Great Teacher of Men": The Role of Peers,
Position Coaches, and Masculinity in a Division | Football Team

» Mr. Anthony Dilascio

Environmental Degradation and Food Systems in Ghana: Gold
Mining and Synthetic Pesticides

» Ms. Da'Mirah Vinson

Growing Needs: How Food Security Influences Community Garden
Participation

» Mr. Kekoa Quisano

Effect of Co-worker Support, Manager Support and Meaningful
work on Job Satisfaction: An Analysis of Generational Differences

» Ms. Eva Tartakovsky, Dr. Tufan Ekici

Kinship Networks as Childcare Providers Under the Two-Child
Benefit Limit in Great Britain

» Ms. Umang Dhingra

Talking Politics and Doing Masculinity
» Mr. Niko Lutz

Community, Empowerment and Social Justice: An Oral History of
the YWCA of New Britain, CT

» Ms. Christina Bean, Mr. Joel Erazo

Refreshment Break
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2pm

2pm

2pm

2pm

2pm

2pm

2pm

2pm

Committee on Status of Ethnicity, Race & Racism (CSERR) meeting
Penn Quarter

AMC: Test, Measure, Punish: How the Threat of Closure Harms
Students, Destroys Teachers, and Fails Schools. By Dr. Erin Michaels

London 2

Test, Measure, Punish: How the Threat of Closure Harms Students,
Destroys Teachers, and Fails Schools

» Dr. Erin Michaels, Dr. Carla Shedd, Dr. Mahala Stewart, Dr. Jessica
Hardie, Dr. Vesla Weaver

AMC: Race, Class, and Affirmative Action: College Admissions after
Students for Fair Admissions v. Harvard. By Dr. Julie Park

Salon C

Race, Class, and Affirmative Action: College Admissions after
Students for Fair Admissions v. Harvard

» Dr. Julie Park, Dr. Karly Ford, Dr. Carson Byrd, Dr. Natasha Warikoo,
Dr. Tiffany Huang

The Critical Sociology of Death: Plenary Session: Toward a Decolonial
Sociology of Death

Salon E

Transforming and Repairing Health Professions Education Mini-
Conference: Individual-Level Reparative Strategies for Coping and
Resistance

Salon 1

(Not) Doing Politics: Intensive Care Work and Depoliticizing Care
During COVID-19

» Dr. Jason Rodriquez
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2:15pm

2:30pm

2:45pm

2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

2pm

“It Feels Like a War"”: How Providers of Gender Affirming Medical
Care at LGBTQ+ Centered Organizations Navigate Unsettled Times

» Mx. Bec Stargel

People Like Me or Patients Like Me?: How Underrepresented
Minorities Choose Residency Programs

» Dr. Nicole Perez, Dr. Laura Hirshfield

Building and Borrowing Legitimacy in Patient Interactions
» Dr. Emily Ekl

Bringing the People Back In Mini-Conference: People in Politics:
Campaigns and Elected Officials

Salon 2

Political Campaign Career Trajectories
» Dr. Wendy Li, Mr. Alex Torpey

Quitting Congress: How Racialized Organizations Influence the
Voluntary Departure of Marginalized Workers

» Dr. Nicholas Occhiuto, Ms. Yee Lok Wong

Opinion Crafting and the Campaign for Right-to-Work in America’s
Industrial Heartland

» Dr. Johnnie Lotesta

Abandoned by Everybody Else: Local Black Organizations,
Inequality and the Legacy of Mobilization

» Dr. Christine Slaughter

Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Climate Attitudes,
Perceptions, and Narratives

Salon B

Global warming’s “Six Americas” in agriculture: Exploring lowa
farmers’ attitudes towards adaptive and mitigative responses to
climate change

» Dr. ]. Gordon Arbuckle, Dr. Laurie Nowatzke
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2:15pm Political Polarization of Environment and Climate: A Dominance
Analysis Perspective

» Mr. Frederic Traylor

2:30pm Is the renewable energy industry a tool to fight climate change?
» Dr. Michael L. Dougherty, Ms. Nicole Batkiewicz

2:45pm How Extreme Weather Experience and Social Trust Improve Trump
Voters’ Climate Change Perception? — Examining A National
Survey before the 2024 Presidential Election

» Dr. Feng Hao

2pm Sociology of Reproduction Mini-Conference: Reproductive
Healthcare
Salon D

2pm Racism in the Birth Room: Obstetric Violence in the US Context

» Dr. Carolyn Fraker

2:15pm Racial Cuts: Black Maternity Care Patients in Cesarean Birth
Discourse
» Dr. Shannon Carter, Ms. Jonzelle Bell, Ms. Sara Tehrani, Ms. Sanjana
Bhatt

2:30pm Pregnant mobilities: Lessons from social media about

transregional liminality for pregnant people navigating the U.S.
healthcare system

» Dr. Zoé Hendrickson, Ms. Elizabeth Evans

2:45pm Doctrine or Diagnosis: How Does Women'’s Miscarriage
Management Differ in Catholic vs. Secular Hospitals?

» Mrs. Claire Anderson
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2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

Decolonial Sociology in Times of Resistance Mini-Conference: Ethics,
Moral Accountability, and Decolonizing Dominant and Subaltern
Subjectivities

Salon 3

From Awareness to Action: Majority Women'’s Ethical Awakening
in Japan’s Anti-Base Movement

» Dr. wakako satomura

Stoicism as Affective Governance: Technologies of the Self under
Racial Capitalism

» Dr. James Love

(De-)Zionizing Jewishness, (De)colonizing Palestine
» Mr. Andrew Shapiro

How Whiteness Killed Us: An Autopsy and a Proposal for Rebirth
» Mx. Olivia Snarski

Undergraduate Student Posters: Session V

Race, Religion & Incarceration: The Shifting Meaning of
Conversion to Islam in Neoliberal America

» Ms. Sanya Ansari

Analyzing Public Displays of Affection Cross-Nationally
» Ms. Celia Long

Applying W.E.B Du Bois’ Critique of Methodological Nationalism to
an Analysis of the Health Crisis in Rural Native American Reserves

» Ms. Kate Vincent

The Legacy of Historic Redlining in Connecticut; Concentrated
Disadvantage and Mental Well Being.

» Mr. Matthew Dworkowitz, Dr. Patricia Lewis

Listening to Employees of Color
» Ms. Kira Chinici
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Continued from Friday, 6 March How Far We've Come, A look at the progress of US Disability Rights
through the lens of segregated schools for the blind in New York

City
A Spatial Analysis of Extreme Heat in Carceral Facilities » Dr. lliana Meiia

» Dr. Galia Shokry, Ms. Theresa Lee, Ms. Sydnie Bogan
On the Horizon of a Pink Imperial Sun: Pink Globalization and the

The Ghost of Jezebel by Chanell Cuevas Philippines

» Ms. Chanell Cuevas » Ms. Hannah Adames

Bagels With Lox and Cream Cheese: Urban Identity as Resistance Socioeconomic Disparities in Malaria Prevention and Treatment
and the Case for New York City Access: A Public Health Perspective from Togo

» Ms. Gabriela Meschoulam » Mr. Yamin Titikpina

Free and Fare: How Commute Burdens Further Displacement and
Reinforce Social Inequities

» Ms. Elana Doren

Navigating Federal Pressure: Community Health Organizations’
Adaptation and Resistance to Policy Shifts

» Ms. Zoe Solberg

“The neighborhood knows itself best: How Localized Decision- 3:30pm International & Alternate Institutions: Tensions and Solidarities
making Processes Function to Represent the True Community in
Which They Occur" London 1

» Ms. Ada Shookenhuff

3:30pm The Paradox of International Aid: Perspectives of the Giver and

Navigating Two Worlds: Recruiting Bilingual Criminal Justice the Receiver

Students at Two CUNY Hispanic-Serving Institutions » Ms. Halle Wimette
» Ms. Sancheska Tapia
3:45pm Bandung Conference to the South-South Cooperation:

Alternatives during the Multipolar World Order from Global
Historical Sociology Perspective

» Mr. Mehdi Hoseini

The Quiet Mechanism of Colonial Impact: Affective Order in the
Built Environment

» Mr. Marco Alvarez

Place and Public Space: Gentrification and Placemaking in the 4pm We Keep Us Alive: Mutual Aid and Harm Reduction as

South Bronx Worldmaking Practices

» Ms. Safiatou Bah » Ms. Danielle Stoneber

Practicing a new world: Columbia University and the Gaza 4:15pm Fire Policies and Indigenous Rights Across Mexico, Central and
Solidarity Encampment South America

» Ms. Tiana Quon » Dr. Kathleen Fallon, Ms. Merica Griffin
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4:30pm

3:30pm

3:30pm

3:43pm

3:56pm

4:09pm

4:22pm

3:30pm

3:30pm

How Typical are Flagship Zen Centers: Examining the Programs of
American Zen Communities

» Dr. Rebecca S.K. Li

Structures of Immigrant Belonging and Exclusion
London 2

Media Myths and Identity: Colombian Immigrants in Boston
» Mrs. Isabella Epshtein

“They don’t belong here”: Understanding American Opposition to
Undocumented Immigration

» Ms. Greta Nelson

Race, Color, and Wealth Accumulation - Conceptualizing the
Racial Identification Process for New Immigrants in the United
States

» Dr. Chunhui Ren

Contributions and Challenges of the H-1B Visa Program in the
United States: Insights from the Washington, D.C. Metropolitan
Area

» Dr. Michelle Dromgold-Sermen, Dr. Sandip Sureka, Ms. Maira Arantes
Rodrigues

Public Sociology and the Lived Contradictions of Internalized
Racism: Religion, Colorism, and Gender across African American
and Migrant Communities

» Mr. Mubarak O Alabi

Social Reproduction and Transitions
Salon C

Shades of Belonging: Racial Capitalism and the Reproduction of
Korea's Multicultural Families through Language and Care Work

» Ms. Rachel Guaderrama
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3:43pm

3:56pm

4:09pm

4:22pm

3:30pm

3:30pm

3:30pm

3:45pm

4pm

4:15pm

Social Reproduction and Imperial Contexts: Beyond the Value
Production Debate

» Ms. Miranda Grundy

Social Reproduction in Racial Capitalism: The Case of ‘White by
Night’ Law in Apartheid South Africa

» Dr. Sonal Sharma

Gender Transition and Reproduction
» Mx. Carlo Sariego

Crushing Rush? How anti-Greek activism impacted student
decision-making around rush.

» Dr. Monique Harrison, Mx. Cade Pretorius

Presidential Plenary: Free DC & Empower DC: Organizing for a
Democratic Future in the Nation’s Capital

Salon E

Transforming and Repairing Health Professions Education Mini-
Conference: Transforming Health Professions Education Via
Organized Resistance

Salon 1

Relearning How We Tell Patients: Transforming Health Professions
Education in Cancer Diagnosis Disclosure

» Ms. Virginia Leach

Small Acts of Resistance: Teaching, Language, and World-Making
in Public Health Education

» Dr. Tariem Burroughs

Transforming the Medical Student Habitus: Imagining Clinical
Ethnography as Justice-Oriented Praxis

» Dr. Hannah Connolly

Untangling the Motivational Complexity of General Surgery
Residents to Unionize: A Dual Framework for Understanding

» Dr. Maya Hunt, Dr. Nicole Perez, Dr. Amy Holmstrom
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3:30pm

3:30pm

3:45pm

4pm

4:15pm

3:30pm

3:30pm

3:45pm

Bringing the People Back In Mini-Conference: People in Politics:
Bureaucrats and Policymaking

Salon 2

Taking the “Lipstick Lobby Brigade” Seriously: Women Lobbyists in
US National Politics during and after World War Il

» Dr. Shamira Gelbman

Protracted Precarity: The Politics of Temporary Protected Status,
1990-2025

» Ms. Neha Lund

Restoring delegation, decision-making, and democratic inclusion
at the National Institutes of Health

» Dr. Natalie Aviles, Dr. Mark Histed

What does the public think? Assessing assumed mechanisms for
the theory of symbolic representation in healthcare

» Dr. Kenicia Wright

Environmental Sociology: Transformation and Repair in
Constraining Environments Mini-Conference: Politics and
Policymaking

Salon B

The Monkey Wrench Gang: Identifying Obstruction in the United
Nations Climate Negotiations with Artificial Intelligence

» Dr. lan Gray

Connection and Contestation: Organizations, Networks, and
Climate Change in U.S. Environmental State

» Mr. Patrick CoatarPeter
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4pm

4:15pm

3:30pm

3:30pm

3:45pm

4pm

4:15pm

4:30pm

3:30pm

The Contested State Embedded in Global Value Chains:
Transnational Dynamics of Sustainable Disclosure Regulation in
Taiwan

» Mr. Chun-Ching Tu

Women, indigenous peoples, local communities, migrants,
children, and persons with disabilities: how inclusive language
became the newest trend in international policy-making on
climate change

» Dr. Danielle Falzon, Mr. Douwe Van Schie

Sociology of Reproduction Mini-Conference: Reproductive
Healthcare Experiences

Salon D

Spatial Stigma and Reproductive Healthcare in Appalachian Ohio
» Ms. Danielle Amezcua, Dr. Cynthia Colen

When Empowerment Matters: Women's Reproductive Health-
Seeking Behaviors in Nigeria

» Dr. Sangeeta Parashar, Ms. Lucia Grattone Cambrun

Flipping the Script: Somatic Inversions During Pregnancy

» Dr. |essica Poling

Reproductive Health Care Access for College Students During and
After Disasters

» Dr. Melissa Villarreal, Dr. Sarah DeYoung, Dr. Virginia Berndt

Title: "I just felt like | was going to die at any moment": Fear,
Uncertainty, and the Emotional Landscape of Post-Dobbs
Abortion Seeking

» Dr. Amy Alterman, Dr. Jessica Gipson

Decolonial Sociology in Times of Resistance Mini-Conference:
Institutional Politics, Representation and Memory

Salon 3
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3:30pm

3:45pm

4pm

4:15pm

3:30pm

Labor, Liberation, and the Limits of Neutrality: Palestine
Solidarity Organizing in a U.S. Academic Union

» Mr. Veenit Singh

Remembering Biko in the Age of Fallism: Media Memory and
Symbolic Resonance in Post-Apartheid South Africa

» Ms. Skylar Li

‘Uncontrollable’: Black Girls, Statecraft, and the Denial of
Childhood in Jamaica

» Dr. Sadivah Malcolm-Wallace

The African Renaissance: Reimagining African Freedom in Cairo
» Dr. Anaheed Al-Hardan

Undergraduate Student Posters: Session VI

Al Use for Emotional and Academic Purposes among College
Students

» Ms. Katelyn Conrad, Ms. Katie Bloom, Ms. Susanna Hardee, Ms. Emily
Klein-Luce

Beauty Standards, Attraction, and Sexuality Among College
Students

» Mr. Jaylin Liggins, Mr. Liam Leffers

College, Culture, and Community: The Personal Impact of The
Rocky Horror Picture Show on the attendees of a small, liberal,
private arts college.

» Ms. Ja'mya Parker, Ms. Angelina Acosta, Ms. Ann West

A Sociolegal Analysis of Surrogacy Case Law in the United States
» Mr. Adan Bernard

Childhood Sexual Violence and Adult Health Outcomes
» Ms. Dehjah Drye, Dr. Ryan Talbert
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Perceived vs. Objective Neighborhood Characteristics and their
Associations with Sleep Duration and Sleep Trouble in U.S.
Adolescents

» Ms. Vangmayee Upadhyay, Dr. Ryan Talbert

The Neurological and Psychiatric Manifestations of Adoption and
Foster Care by Race and Gender

» Ms. Akeva Koulla, Dr. Ryan Talbert

The Relationship Between Neurocognitive Functioning,
Depression, Suicidal Ideation, and Attractiveness in Athletes

» Ms. Alexandria Dominique, Dr. Ryan Talbert

Green Spaces, Marginalization, and Mental Health
» Mr. Logan Mallory

How Students at a Small Liberal Arts College Make Sense of
Declining Trust in U.S. Government Institutions

» Mr. Stephen Dumaresq

Mapping Police Involvement in Mental Health Emergencies
» Ms. Brie Schaffer, Prof. Rebecca Gleit, Prof. Amy Johnson, Ms. Elsa Jin

Preservation, Conservation, and Continuation
» Mr. Thomas Troesch

Social Media's Affect on Critical Consciousness in First Generation
American Immigrants

» Ms. Sophie Vaz

Understanding Public Perceptions of Police Surveillance: The Case
of Detroit's Project Green Light

» Ms. Stella Brown, Prof. Rebecca Gleit, Ms. Shuhan Ye, Ms. Emma
Bedard

Adolescent Substance Use and School Success
» Ms. Calista Nohai-Seaman
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5pm

I 6pm

Anti-Immigration Attitudes & Support for Donald Trump in the
2024 Presidential Election

» Ms. Marilyn Roque-Velasquez

Childhood Social Class and Adult Outcomes
» Ms. Karlita Karczewski

Christian Nationalism as an Exclusionary Framework: The
Boundaries of Empathy

» Ms. Francesca Bambara

Social Mobility and Gender Role Attitudes in the United States
» Ms. Norah Seidler

Awards Ceremony

Presidential Address and Reception

Saturday, 7 march

8am

8am

8:13am

8:26am

Racial Disparities, Dynamics, Tensions
Salon B

“Race, Ethnicity, and the Value of Cultural Competence in Health
Care: An Analysis of NHIS 2017 Data”

» Ms. Madison Centeno

Oral Health Care Visits and Systemic Inflammation
» Ms. Safivah Ahmed

“Why is That Your Race?” Racial Identity and Racial
Conceptualization

» Mr. Mason Carter, Dr. Raj Ghoshal

Powered by Ex Ordo, everything you need to run a research conference.

8:39am

8:52am

8am

8am

8:15am

8:30am

8:45am

8am

8am

8:15am

Internalizers or Resisters? : Heterogeneity in Blacks' Opinion
Towards Affirmative Action Policies in the US

» Ms. Namrata Shokeen

A Qualitative Exploration of the Race Paradox and Adolescent
Mental Health

» Dr. Tia Dickerson, Ms. Rachel Brown-Weinstock

Food Systems & Repair
London 1

Community Efficacy for Nutritional Repair: Assessing the role of
community actions towards food justice and nutritional equity.

» Mr. Drew Bonner

Why Are Food System Workers Excluded from Local Food Policy
Councils?

» Mr. Frank Sarfo, Dr. Laura-Anne Minkoff-Zern, Dr. Jonnell A. Robinson

An Exploration of Food Bank Resources in the Midwest United
States - Distribution based on Race, Poverty, and Rurality

» Ms. Annalise Frodermann, Mr. Akira Nishi, Mr. Daniel Zacher, Dr.
Alana Haynes Stein

Framing Taste: Digital Food Policy Archive and Food Stories
Project

» Dr. Danielle Duran

Structures of Support on the Margins
Salon C

How Loved Ones of the Incarcerated Seek and Share
Informational Support on Facebook

» Ms. Jayla Gray-Thomas

Deserving or Deviant? Understanding Support for Homelessness
Policy

» Mrs. Amanda Pierson
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8:30am

8:45am

8am

8am

8:15am

8:30am

8:45am

8am

8am

A System Stacked Against Them: A Quantitative Analysis of
Misconduct among Incarcerated Men with and without
Intellectual or Developmental Disabilities

» Ms. Lilli Hennig

Mutual Aid in Prison and Re-entry: Bounded community

» Prof. Chrysanthi Leon, Ms. Payton Eckell, Ms. Rabia Hussain, Ms.
Sadie Polk, Ms. Ajah Edwards, Ms. Lucy Nistler

Civil Disruptions, Engagements, and Repair
London 2

From Headlines to Laws: The Social Construction of Climate
Havens through Media and Policy Narratives

» Dr. Elizabeth Kiester, Dr. Elizabeth Eklund, Dr. Saleh Ahmed

Towards an Autochthonous, Community-Centric Approach to
Disaster Risk Reduction: A Framework for Engaging with
Recovering Communities in Research Collaborations

» Dr. Jenniffer Santos-Hernandez

Civil Disruption
» Dr. Dean Ray, Dr. Reece Peck

The Glocal Right Circuits in Transformation: Mapping the
Transnational Flows of Anti-LGBTQ Conservatism and Struggles
between Taiwan and the United States

» Dr. Ying-Chao Kao

Gender Roles (Sponsored by Committee on Gender Equity)
Salon 1

Integrative Pathways of Ethnic Retention: Gendered Dimensions
of Cultural and Religious Continuity

» Dr. Maheen Haider
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8:13am

8:26am

8:39am

8:52am

8am

8am

8:15am

8:30am

8:45am

8am

Intra-Couple (Dis)Similarity in Gender Role Attitudes and Higher-
Order Births in China

» Ms. liaxuan Huang

“The Land of Rising Celibacy”: Desexualization and Perceptions of
Japan's Economic Decline

» Dr. Anna Wozny

Limerence and Gender: Critical Perspectives on Love, Abuse, and
Violence

» Ms. Cassie Sistoso

Sixteen Candles, Sex & the City, and the Names Parents Choose
for their Children

» Dr. Michelle Napierski-Prancl

Image, Stigma, and Repair
Penn Quarter

The Presentation of the Sick or Disabled Self in Public Life: A
Comparative Case Study of Three U. S. Presidents: Woodrow
Wilson, Franklin Delano Roosevelt, and John F. Kennedy

» Dr. jonathan reader

Reputational Response: Image Repair Beyond Benoit's Framework
» Ms. Grace Furlong

An Intersectional Analysis of Stigma among Female College Sugar
Babies

» Mr. Darion McKinley

Analyzing the Portrayals of Immigrants in Political Comics
» Mx. G Smith-Rasmussen

Yet Another Costume Party Debacle: Why Racial Ignorance Persists
on Elite College Campuses, by Dr. Ingrid Nelson - Bowdoin College

Salon E

Page 37


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Saturday, 7 March

8am

8am

8am

8:15am

8:30am

8:45am

8am

8am

8:13am

Yet Another Costume Party Debacle: Why Racial Ignorance
Persists on Elite College Campuses

» Dr. Ingrid Nelson, Dr. Karly Ford, Dr. Julie Park, Dr. Blake Silver, Dr.
Elizabeth Lee, Dr. Alex Manning

Transnational Asian/America Mini-Conference: Racialization Across
Borders

Salon A

Asian, Black & Blasian Bridgeworkers: Racialized Communities in
Translation

» Mx. Sera Kwon

Beyond Internment and Jim Crow: Japanese Americans at Fisk
University and the Transnational Racial Imagination of Postwar
America

» Dr. SunAh Laybourn

Seeing Africans in China: A Survey on Africans in the Eyes of
Chinese Locals

» Dr. Xuemeng Li

The Significance of Early “Significant Others”: Family, Friends, and
Racialized Desire Among East Asian Women

» Dr. Olivia Hu

Sociology of Reproduction Mini-Conference: Reproductive Justice
Salon D

Reproductive Justice is Disability Justice and Disability Justice is
Reproductive Justice

» Ms. Lauren Danielowski

Gender Differences in Childfree Discourse: A Discourse Analysis of
Reddit Communities

» Ms. Fanmei Xia
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8:26am

8:39am

8:52am

8am

8am

8:15am

8:30am

8:45am

9:30am

9:30am

Kinship, Care and Choice: Negotiating Othermothering and
Gendered Expectations of Care as Childfree Black Women

» Ms. Olivia Davis

Jewish Mothering, Reproductive Justice, and Kinship Post-October
7th

» Dr. Derek Siegel

Autonomous Health Movements and the Construction of
Community Health Knowledge

» Mx. Bex Groth

Decolonial Sociology in Times of Resistance Mini-Conference:
Modernity, Development, and Sociology's Imperial Underbelly

Salon 3

Cold War Epistemologies, Expert Networks, and Liberal
Internationalism

» Dr. Despina Lalaki

Sociology’s Settler Roots: Remembering The Discipline’s
Entanglements with Settler-Colonial Projects and Statecraft

» Ms. Upasana Goswami

The Janus Face of Social Darwinism: Survivalist Reception in Asia’s
Encounter with Western Power

» Dr. Xuewen yan

Decolonizing Modernity across time and space: From Western
Modernity to Critical Global Modernity through Triangulation

» Prof. Fatma Muge Gocek

Trans Lives (Sponsored by Committee on Gender Equity)
London 1

Empowering “Transtopia” in an Anti-Trans Era: Taiwan's
Institutionalization of Gender Equity Education and Its Trans*-
formative Effects in the Transnational Democracy

» Dr. Ying-Chao Kao
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9:45am

10am

10:15am

9:30am

9:30am

9:30am

9:30am

9:30am

9:30am

Disability, Gender Identity, and Everyday Discrimination: Evidence
from the U.S. Transgender Population Health Survey

» Mr. Reid Boujaoude, Dr. Janet Wilmoth

Breaking the Binary Response: Disaster Impact on Trans and
Queer Mental Health

» Mx. Fran Vidal-Franceschi

"It's really hard to choose between the sport that you love or
transition": Experiences of transgender athletes in the NCAA

» Mx. Alexander Perry

AMC: Beautiful Solidarity, Symbolic Impacts: 2020 Racial Justice
Uprisings by Eileen O'Brien (UGA Press, June 2025)

Salon B

Beautiful Solidarity, Symbolic Impacts: 2020 Racial Justice
Uprisings by Eileen O'Brien (UGA Press, June 2025)

» Dr. Eileen O'Brien, Dr. Angie Beeman, Dr. Andrea Simpson, Dr. Toorjo
Ghose, Dr. Deirdre Royster, Dr. Charles Gallagher

AMC: Not All In: Race, Immigration and Healthcare Exclusion in the
Age of Obamacare. By Dr. Tiffany Joseph

Salon C

Not All In: Race, Immigration and Healthcare Exclusion in the Age
of Obamacare

» Dr. Tiffany Joseph, Dr. Jean Beaman, Dr. Ernesto Castaneda, Dr.
Celeste Currington, Dr. Hilary Silver

Schooling, Being & Wellbeing
Salon E

The Experiences of School Social Workers in the New York City
Public School System

» Dr. Joseph Twumasi-Ankrah
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9:43am

9:56am

10:09am

10:22am

9:30am

9:30am

9:30am

9:30am

9:30am

Moral Distress Among Teachers, Counselors, and School
Administrators in the Aftermath of Neighborhood Gun Violence

» Dr. Nora Gross, Mr. Alexander Pereira, Ms. Anika Lanser, Ms. Kelly
Yoshimura

Youth-led Research on School Safety: A Study by the Youth
Research Council

» Dr. Meagan Call-Cummings, Dr. Khaseem Davis, Mx. Youth Research
Council Fellows, Dr. Mia Hines

Counseling at the Margins: Role Ambiguity, Burnout, and
Counselors’ Work with Immigrant Students

» Dr. Alessandra Bazo Vienrich, Ms. Amaya Fiske

Tracing the Life Course of Surveillance: How Primary and
Secondary School Monitoring Shapes Perceived Safety in Higher
Education

» Mr. Devon Skufca, Mrs. Miranda Habrecht

Panel: The Paradoxes of State and Scientific Enroliment
Tokyo

The Paradoxes of State and Scientific Enroliment

» Prof. Claire Decoteau, Dr. Emily Vasquez, Dr. Cal Garrett, Dr.
Katharine McCabe

AMC: Is It Racist? Is It Sexist? Is It Racist? Is It Sexist? Why Red and
Blue White People Disagree, and How to Decide in the Gray Areas.
By Dr. Betsy Leondar-Wright and Dr. Jessi Streib

London 2

Is It Racist? Is It Sexist? Proposal for Author Meets Critic session

» Dr. Betsy Leondar-Wright, Dr. Jessi Streib, Dr. Daniel Laurison, Dr.
Musa al-Gharbi, Dr. Jessica Welburn Paige

Transnational Asian/America Mini-Conference: Collective Action and
Mobilization on the Global Stage

Salon A

Page 39


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Saturday, 7 March

9:30am

9:45am

10am

9:30am

9:30am

9:43am

9:56am

10:09am

Caste & Lawfare: Anti-Caste legislations, Hinduphobia and the
case of global Hindutva in the US

» Ms. Debadatta Chakraborty

Making Converts out of Asylum-Seekers: Korean Immigrant
Evangelical Church and Asylum Claims-Making on Religious
Grounds

» Prof. Jaeeun Kim

Beyond a Symbolic Community? Asian Americans, Cultural Status
Beliefs, and the Strategic Action Field of Racial Inequality in
Education

» Mr. Yang Hai

Black Placemaking and Worldmaking: Space, Power, and Possibility
Mini-Conference: Gentrification, Displacement, and the Un/Making
of Neighborhoods

Salon 1

A Park as Racial Redress?: Commemoration Against the Backdrop
of Gentrification

» Ms. Asha Larson-Baldwin

“The Richmond Negro”: Neoliberalism, Labor Market
Gentrification, and the Loss of Home

» Ms. Tiamba M. Wilkerson

Where Goes the Hood: Neighborhood Canons, Gentrification &
The Spatial Disruption of Community

» Mr. Payton Johnson

The Brave Lions of Getsemani: Symbols of collective identity and
memory in the time of displacement

» Dr. Melissa Valle
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10:22am

9:30am

9:30am

9:45am

10am

9:30am

9:30am

9:43am

9:56am

10:09am

Choosing Third Ward: What Attracts the Black Middle-Class to the
Contemporary Black Metropolis?

» Dr. Shani Evans, Ms. Victoria Graham

Bringing the People Back In Mini-Conference: Right-Wing Politics
Salon 2

Losing Our Kids: Intergenerational Disjunctures as
Emotional Scaffolding for Right-Wing Populism

» Ms. Rachel Brown-Weinstock

Inclusive Populism: the Antidote to Authoritarian Pseudo-
Populism

» Mr. Jonathan Smucker

After Colorblindness: The Emerging Racial Autocracy
» Dr. Victor Ray

Sociology of Reproduction Mini-Conference: Parenting
Salon D

The Labor of Love and the Consumption of Care: Reproductive
Work, Emotion, and Agency in Domestic Life

» Ms. Pang-Yuan Chen

To Be or Not to Be a Parent? Reproductive Decision-making
Among Young Gay Men in China

» Ms. Scarlett Qian

Motherhood through the Use of Donated Eggs or Embryos: How
parents craft narratives around donor use and the Origin Stories
they tell their child”

» Prof. Rosanna Hertz

Competing Interests or Increased Stakes? A Study of Voting and
Interest in Public Affairs Across the Transition to Parenthood

» Dr. Desmond Wallace, Dr. Arthur Greil, Dr. Julia McQuillan, Dr.
Kathleen Slauson-Blevins, Dr. Michele Lowry
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10:22am

9:30am

9:30am

9:45am

10am

10:15am

10:45am

T1am

T1am

11:15am

Parental Acts of Resistance: Reproductive Identity and
Reproductive Justice for Emerging Adults with Intellectual and
Developmental Disabilities

» Ms. Alisa Sholomon, Ms. Regan Moss, Ms. Cecily Murphy, Dr. Aurelie
Athan, Dr. Christine Drew

Decolonial Sociology in Times of Resistance Mini-Conference: Anti-
colonial Solidarities and Transnational Networks Across Movements

Salon 3

“Our Good Friends from Israel have Been Here": Confronting
Militarism in Hawai'i through Spatial and Temporal Solidarities

» Dr. Heidi Nicholls

The Bolshevik Laboratory of Anti-Colonial Thought
» Mr. Udeepta Chakravarty

The Confines of U.S. Exceptionalism : Du Bois’ Critique of the
NAACP's Disengagement with the Pan-African movement

» Dr. Julia Bates, Ms. Kate Vincent

Social Movements, Palestine, and the University
» Prof. |essica Hardie

Refreshment Break

Anti-Blackness, Policy, Wealth, and Segregation
Salon E

The Invisibility of Black Wealth in Texas History: A Jim Crow Case
Study

» Dr. Hollie A. Teague

The Legacy of Redlining: Impact on modern crime in San Diego
» Ms. Camille Fei, Ms. Natalie Harkins, Prof. Ramiro Martinez
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11:30am

11:45am

11am

T1am

11:15am

11:30am

11:45am

11am

T1am

11:13am

Social Isolation in Motion: How Socioeconomic Segregation in
Everyday Mobility varies by Neighborhood Racial-Ethnic
Composition in U.S. Cities

» Dr. Brian Levy

From Reconstruction to DEI: Historical Attunement and the
Metabolism of Antiblackness

» Dr. Jae Kim

Privilege, Risk, and Precarity
London 1

“Precarious Privilege: Transgender Accounts of Male Privilege and
Intersectional Masculinity”

» Dr. Armani Beck

Privilege and Overconfidence in Vehicle Submersion Emergencies

» Dr. Elizabeth Borland, Ms. Jenna Needham, Dr. Mary Nell Trautner,
Ms. Amber Rollins, Ms. Janette Fennell

Dismantling ableist privilege - how to conscientize ourselves and
others?

» Dr. Linda Madden, Dr. Penelope Carroll, Prof. Karen Witten

"No Step on Snek": How Digital Gun Culture Fuels the Intersection
of Online Male Supremacy and Anti-Government Extremism

» Ms. Jennifer West, Dr. Pasha Dashtgard, Ms. Kaitlyn DaVisio

Activism and Feminism (Sponsored by Committee on Gender Equity)
Salon C

The Architecture of Feminism
» Dr. Carla Corroto

Archives as Spaces of Queer Worldmaking
» Ms. Debamita Guha
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11:26am

11:39am

11:52am

11am

T1am

T1am

T1am

T1am

11:15am

Constructing a Black Feminist Standpoint on Pleasure
» Ms. Maya Glenn

"We Still Were Confronting What We Were Trying to Dismantle”:
Stories on Leadership and Politics in Community-Based
Participatory Action Research

» Prof. Judy Pryor-Ramirez, Ms. Sophia George, Ms. Alicia Alvarez

Violence of Distancing and LGBTI+ Remote Activism in Turkiye
» Dr. Emine Ece

Brothers in Grief: The Hidden Toll of Gun Violence on Black Boys and
Their Schools, by Nora Gross

Penn Quarter

Brothers in Grief: The Hidden Toll of Gun Violence on Black Boys
and Their Schools

» Dr. Nora Gross, Dr. Allison Pugh, Dr. Brandon Jackson, Dr. C. Shawn
McGuffey

Public Sociology: Dreaming in and Beyond the Academy Toward a
Meaningful Career (Professional Development Spotlight)

Tokyo

Transnational Asian/America Mini-Conference: Identity Formation
and Belonging in Asian America

Salon A

Weaving the Racial Uniform: The Construction of "Asian
American" Belonging

» Mr. Ryan Santa Elena

Precarious Lives: Temporality & Assimilation among Chinese
International Student

» Ms. Eva Chen
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11:30am

11:45am

11am

T1am

11:15am

11:30am

11:45am

11am

T1am

Sexual Betweenness and Intersecting Exclusion of Queer Chinese
Adolescent Immigrants: Making a Case for Sexuality in Immigrant
Incorporation

» Mr. Frank Meng

Learning Marx in China, Meeting Jesus in America: Chinese
International Students in the Christian Church

» Mr. Zhihao Pan

Black Placemaking and Worldmaking: Space, Power, and Possibility
Mini-Conference: Memory Landscapes: Monuments, Museums, and
Remembrance

Salon 1

Black Placemaking and Community Responses to Representations
of the Civil War

» Dr. Claire Whitlinger, Dr. Heather O'Connell, Dr. Ashley Reichelmann

Beyond the Monument: Material Culture, Identity, and Black
Place-Making in the National Museum of African American
History and Culture (NMAAHC)

» Ms. Jamya Robinson

Placemaking, black space, white spaces and parades
» Prof. Colin Adams

Living Archives and Resistant Ecologies: Black and Indigenous
Worldmaking in Dominica

» Ms. Faith Deschamps

Bringing the People Back In Mini-Conference: Local Politics &
Community Power

Salon 2

"Better than Nothing or the Dopest Casino on the Planet?":
Controversial Urban Development Projects, Community
Leadership, Brokerage, and Power

» Mr. Thomas Corcoran
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11:15am

11:30am

11:45am

T1am

T1am

11:13am

11:26am

11:39am

11:52am

Patterns of Neighborhood Deliberation: ATypology of Local
Democratic Participation

» Ms. Rehana Odendaal, Mr. Dylan Van Duyne

Dealignment, Post-Capitalism and Working-Class Consciousness:
An Empirical Synthesis

» Dr. Peter |keler

Beyond Race and Gender: Understanding how intersectional
identities influence “Women of Color” Mayoral candidacies

» Dr. Paru Shah, Dr. Nadia Brown

Sociology of Reproduction Mini-Conference: Biomedicalization of
Reproduction

Salon D

Commodifying Conception: Sociological Dimensions of Venture
Capital and Private Equity in Reproductive Medicine

» Dr. Evelina Sterling

Community Birth Workers and Digital Disaster Care: Pregnancy
Management in Puerto Rico Post-Hurricane Maria

» Ms. Emaline Reyes

The Biomedicalization of Advanced Maternal Age: How
Technoscientific Risk Management Shapes the Experiences of
Women having First Births at Age 35 and Older

» Dr. Emily Mann

Reproductive Psychiatry, Risk & The Politics of Maternal Mental
Health

» Ms. Charlotte Abel

Dimensions of accepting, resisting, and desiring cesareans:
Women's pregnancy and birth experiences in Mumbai, India

» Ms. Surbhi Shrivastava
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11am

12:30pm

12:30pm

12:45pm

1:15pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

Decolonial Sociology in Times of Resistance: Lunch Break
Salon 3

Worldmaking, Meaning, and Action
Salon B

Worldmaking from Dispossession: Dalit Political Realignment in
the Context of Kerala Model of Development

» Mr. Arvind Geetha Christo

The Revolt of the “Ritualists” and their choice of an “Innovator” as
their Savior: Explaining the Maga Movement

» Dr. Herbert Ziegler

Performing Democracy amid Backsliding: Campaigns, Coalitions,
and Citizen Meaning-Making in Bihar, India

» Ms. Shivani Choudhary

Homeless Youth: From Prison to Rainbows
» Dr. Omar Nagi, Mr. Elijah Garba, Mr. Armando Herrera

Colliding Worlds: Protesting and Policing
Salon 2

When the State Shows Up: Police Presence, Use of Force, and the
Escalation of Protest Violence

» Ms. Rachel Gorman

When Civility Defines Nonviolent Resistance: The Cultural
Meanings of Peaceful Tactics and Production of Internal
Boundaries in South Korea's Candlelight Protests

» Dr. Junghyun Nam

The Color of Jaywalking: Policing, Race, and Pedestrian Deaths
» Prof. Gregory Smithsimon, Ms. Caitlyn Egan, Prof. Lawrence Johnson

The Pro-Palestinian Niche in Progressive Activism
» Dr. Arman Azedi
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12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

12:43pm

12:56pm

Children and Youth (Sponsored by Committee on Gender Equity)
Salon C

“1did it anyway": Subjugated Feminist Knowledges, Girl Time and
Affective Girls’ Activism in India

» Ms. Namrata Shokeen

Cultural Brokers and Emotional Laborers: Gendered Expectations
of Eldest Daughters in Immigrant Families

» Ms. Tharuna Kalaivanan

Gender-Based Disparities in Digital Capital and Cyberbullying
Experiences: An Empirical Study Among Adolescents.

» Mr. Justice Gmatim, Mr. Daxing Yang

Childhood Intersectionality, Poverty, and the Meaning of Place
» Ms. Haley Beliveau

Worldmaking in Community Colleges: Cultivating Belonging, Agency,
and Community Transformation (Sponsored by Committee on
Community Colleges)

Penn Quarter

Dilemma and Cultural Taxation among the professionals doing
Diversity, Equity and Inclusion work: A case study from CT State
Community College.

» Dr. Nutan Mishra

A Holistic Program for Parenting Students: Worldmaking Begins at
Community Colleges

» Dr. Sarah Hoiland, Dr. JungHang Lee, Dr. Anders Stachelek, Ms. Linda
Sebisaho

Putting the "Community" Back into Community College
» Dr. Romney Norwood
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1:09pm

1:22pm

12:30pm

12:30pm

12:30pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

We March for Community
» Prof. Vondora Wilson-Corzen, Ms. Cyra Perri

Struggling for Access
» Prof. Vondora Wilson-Corzen

AMC: Kindergarten Panic Parental Anxiety and School Choice
Inequality, by Dr. Bailey Brown

London 1

Kindergarten Panic Parental Anxiety and School Choice Inequality

» Dr. Bailey Brown, Dr. Carla Shedd, Dr. Tamara Mose, Dr. Angela
Simms, Dr. Mahala Stewart

The Nuts & Bolts of the Academic Job Market (Professional
Development Spotlight sponsored by Sociological Forum)

Tokyo

Transnational Asian/America Mini-Conference: Between Race and
Culture

Salon A

“Racial Boundaries in the Korean Wave: K-drama Influencers in
the Covid-19 Lockdown”

» Dr. Chinyere Osuji

Negotiating Sustainability: Ecological Liminality and
Transformative Practices in Fifth-Generation K-pop

» Dr. yanghwan Choi

“Asian” in America: The Multiple Dimensions of Race for People of
Asian Origin

» Ms. Jocelyn Drummond

“Minor Feelings": Affective Experience and the Construction of
Ethnoracial Identity

» Ms. Charlotte Wang
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Continued from Saturday, 7 March 1:15pm Living Archives and Resistant Ecologies: Black and Indigenous
Worldmaking in Dominica

» Ms. Faith Deschamps

12:30pm  Black Placemaking and Worldmaking: Space, Power, and Possibility
Mini-Conference: Theorizing Black Worldmaking, Safety and

Universalism 12:30pm  Presidential Plenary: Critical Imaginaries for Worldmaking
Salon 1 Salon E
12:30pm Global Black World-Making, the Limits of Nationalism, and the 1 pm NEW BOOK EXHIBIT RECEPTION
Promise of Anti-Colonial and Anti-Capitalist Universalism Ballroom Floor Atrium
» Dr. Jamella N. Gow
Tpm New Book Exhibit with Authors
12:45pm The tragedy of Black postcolonial political theatre in making Ballroom Floor Atrium
migrant community identities
» Dr. Marcelle Medford 2pm Eroding Safety Nets
London 1
Tpm Blackness as a World Problem
» Dr. Ainsley Lesure 2pm When the Safety Net Shrinks: Local Responses to Increasing Food
Insecurity
12:30pm  Sociology of Reproduction Mini-Conference: Lunch Break » Ms. Tori-Ann Haywood
Salon D
2:13pm Meals on the Go: Exploring the challenges of navigating charitable
12:30pm  Decolonial Sociology in Times of Resistance Mini-Conference: food while homeless
Indigenous Sovereignties » Dr. |lennifer Frank, Dr. Mary Glazier, Ms. Dawn Watson
Salon 3
2:26pm Changing Spaces for Changing Faces: A Case Study of
12:30pm Native American Discrimination within the US Criminal Justice Gentrification, Food, and Class in Williamsburg, Brooklyn
System: Indigenous Legal Ability to Prosecute Criminals » Ms. Kimberly Wong
» Ms. Carissa Christensen
2:39pm Charity, but Not Justice: Consequences of American
12:45pm From Racialized to Resurgent Organizations: Contact, Individualisms
Credentialing, and Indigenous Agency under Settler-Colonialism » Dr. Allan Rachlin
» Dr. Dean Ray, Dr. |effrey Denis
2:52pm 'A Different World': Precarity Chains, Frayed Family Safety Nets,
Tpm Land of 10,000 Ghosts: The Whitewashing of Settler Colonialism in and Interweaving Substances as Factors Contributing to Opioid
Minnesota Ghost Stories Use among the Working Class
» Dr. Kevin Revier » Ms. Erin Tucker, Dr. Victor Chen, Ms. Katrina Hamilton
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Continued from Saturday, 7 March 2:39pm Is the “Second Shift” Now Online? Differences in Teleworking
Between Mothers and Fathers Pre- and Post-COVID-19

2pm Feminist Framings, Sexual Politics, and Media Worlds » Mr. Bektemir Momunkulov
Salon B
. L L . . o 2:52pm Gender and Status in Chat Reference Interactions in an Academic
2pm Anomic confusion in feminism influenced post industrial societies Library: A Machine-Learning Analysis using BERT
2:15pm Politics, Romance and Reality: Responses to Controversial Talk on . . X
Romance Reality TV 2pm Committee on Community Colleges Meeting
» Dr. Leslie Martin, Ms. Jadyn Freeman, Mr. Knox McKinley Tokyo
2:30pm Sex in the Carceral State 2pm AMC: Orienting to Chance Probabilism and the Future of Social
» Mx. Max Calleo Theory, by Michael Strand and Omar Lizardo
Salon 2
2:45pm Drag Queens, King;, ar_1d Things: quup differences in expression,
performance, motivation, and politics 2pm Author Meets Critics: Orienting to Chance Probabilism and the
» Mx. Sky Rathvon Future of Social Theory
» Prof. Michael Strand, Prof. Omar Lizardo
3pm Tradwives, incels, and camgirls: gender, identity, and intimacy in
digital capitalism . X . . . i
. 2pm AMC: Listeners Like Who? Exclusion and Resistance in the Public
» Mr. Adam Gavnik :
: Radio Industry, by Dr. Laura Garbes
Salon E
2pm Digital Lives (Sponsored by Committee on Gender Equity)
Salon C
2pm Listeners Like Who? Exclusion and Resistance in the Public Radio
2pm A Call to Protect?: Rhetorical Strategies in the Propagation of Anti- Industry ) ) o
LGBTQ+ Narratives in the 21st Century » Dr. Laura Garbes, Dr. Victor Ray, Dr. Tania Aparicio Morales, Dr.

) Melissa Abad, Dr. Tsedale M. Melaku
» Mx. Kelani Johnson

2:13pm Gay Bathhouses in the Era of Digital Intimacy 2pm Professional Development Spotlight: Reception (Sponsored by
» Mr. Kurtis Dennison Sociological Forum)
Ballroom Floor Atrium

2:26pm "Carry On My Wayward Son?: The Partial Canonization of Destiel
and the Politics of Queer Media Representation in the New me Transnational Asian/America Mini-Conference: Status, Achievement,
Millennium." and Racialization
» Dr. [aime Hartless Salon A

Powered by Ex Ordo, everything you need to run a research conference. Page 46


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Saturday, 7 March 2pm When the Heart Can’t Take Poor Odds: Negotiating the Risk of
Twins from Fertility Treatment

. - . . » Dr. Eliza Brown
2pm “At the expense of Asians”: Racialized Notions of Merit and

Deservingness in the Debate over Selective Public High School
Admissiogns & 2:13pm Gender, Religion, and Infertility Treatment-Seeking in the United

» Dr. Nora Kim, Mx. Caz Hatton, Mr. William Polaski States .
- » Dr. Kate Tierney, Mx. Logan Deeter

2:15pm Bounded Autonomy: How Information Asymmetries Enable )
Career Negotiation in High-Achieving Immigrant Families 2:26pm

» Dr. Aanchal Manuja

I'll never become somebody’s biological mommy: An
autoethnography of loss

» Dr. Amy Clark

2:30pm Status in flux: how Chinese elite youth construct a contested

status hierarchy 2:39pm Bg\alilgg)ment of a community-level infertility stigma scale in
» Ms. Ruiyi Li » Dr. Suzanne Bell, Ms. Haley Thomas, Dr. Simon Kibira, Ms. Sarah
Nabukeera, Dr. Fredrick Makumbi, Dr. Caroline Moreau
2pm Black Placemaking and Worldmaking: Space, Power, and Possibility
Mini-Conference: Land, Food, Environment, and Economic Futures 2:52pm Quantifying the reproductive labor of pregnancy and pregnancy
Salon 1 loss in the demographic study of population health
» Dr. Payal Hathi
2pm Black Women'’s Food Practices, Placemaking, and Everyday
Resistance in Boston 2pm Decolonial Sociology in Times of Resistance Mini-Conference:
» Ms. Victoria Fuller Decolonizing Social Theory, Re-theorizing Imperiality
Salon 3
2:15pm “The Return to the Land Ain’t Just a Trend, It’s a Revival”: Black
Homesteading as a Racialized Lifestyle Movement 2pm Solidarity Beyond Empire: Theorizing Solidarity from the Global
» Ms. Ryann Monteiro South
» Mr. Muhammad Amasha
2:30pm Ain't Nothin But Dollar General: Reputation Management in an
Environmental Justice Community 2:15pm Decolonizing Subimperialism
» Mr. Major Eason » Dr. Veda Hyunjin Kim
2:45pm Footholds of Flourishing: Economic and Political Strategies for 2:30pm Towards decolonial theory of revolutions
Material and Social Wellbeing in Black Communities » Dr. Atef Said
» Dr. Angela Simms
2:45pm The Rise of Fascism in the Dutch Empire and its Black Radical
2pm Sociology of Reproduction Mini-Conference: Fertility and Infertility Critics
Salon D » Dr. Jacob Boersema
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Continued from Saturday, 7 March

2pm

2pm

3:15pm

3:30pm

3:30pm

3:45pm

4pm

4:15pm

3:30pm

3:30pm

Panel: Inequality, Wealth, and Mobility
Penn Quarter

Inequality, Wealth, and Mobility

» Prof. Dawn Dow, Prof. Shay O'Brien, Ms. Annika Hoeft, Prof. Annette
Lareau

REFRESHMENT BREAK
Ballroom Floor Atrium

Labor and the Workplace
Salon B

Hiring to Displace: How Employers Use Legal Status to Reshape
Workplace Power

» Prof. Laura Lopez-Sanders

“At Your Service”: Race and Recovery in Retail Work
» Ms. Sophia George

USMCA's Rapid Response Mechanism and U.S. Unions’ Turn to
Support: Enforceability over Depth

» Dr. terumasa tomita

Disenchantment, disembedding, and reembedding: Chinese
working holiday makers and the remaking of individual biography

» Ms. Qing Tingting Liu

Committee on Gender Equity Meeting (CGE)
Tokyo

Teaching on the Frontlines: Pedagogy, Belonging, and Emerging
Technologies in the Community College Classroom (Sponsored by
Committee on Community Colleges)

Salon C
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3:30pm

3:43pm

3:56pm

4:09pm

4:22pm

3:30pm

3:30pm

3:30pm

3:30pm

Stop playing whack-a-mole with Al: Directing student Al use as
pedogogical practice

» Dr. Erica Yeager

Ethnographies of Work: Integrating Theories of Labor and Career
Literacy into the Community College Curriculum

» Prof. Carlos Maynard, Dr. Melissa MacDonald, Dr. Aurora Bautista

Letting Students Lead: Practicing Tough Conversations in the Age
of Al

» Dr. Lisa McManus, Prof. Jessica MacDonald

Fostering a Shared Sense of Belonging and Inclusivity in Times of
Oversight: Practical Strategies and Lessons Learned in the
Community College Classroom

» Dr. Hannah Liebreich

"Prompts, Pedagogy, and Progress: An Al Classroom Journey"
» Dr. Paul Calarco

AMC: Who Cares About Parents?: Temporary Alliances, Exclusionary
Practices, and the Strategic Possibilities of Parenting Groups, by Dr.
Kim Price-Glynn

Salon E

Who Cares About Parents?: Temporary Alliances, Exclusionary
Practices, and the Strategic Possibilities of Parenting Groups

» Dr. Kim Price-Glynn

AMC: The Loyalty Trap: Conflicting Loyalties of Civil Servants Under
Increasing Autocracy, by Jaime Lee Kucinskas

Salon 2

AMC: The Loyalty Trap: Conflicting Loyalties of Civil Servants
Under Increasing Autocracy, by Jaime Lee Kucinskas

» Dr. Caroline Lee, Dr. Ruth Braunstein, Dr. Wendy Li, Dr. Michael
Rosino, Dr. Jaime Lee Kucinskas, Dr. Josh Pacewicz
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Continued from Saturday, 7 March 3:30pm Sociology of Reproduction Mini-Conference: Information Session on
the ASA Section in Formation on the Sociology of Reproduction

Salon D
3:30pm Transnational Asian/America Mini-Conference: Global Capital,
Mobility, and Brokerage . . . . . -
Salon A 3:30pm Decolonial Sociology in Times of Resistance Mini-Conference:
Politics of Time and Theorizing for Decolonial Futures
Salon 3
3:30pm Flexible Collaboration: State-Embedded Brokerage by Chinese

Transnational Elites in the China-U.S. Nexus

» Mr. Pengfei Liu 3:30pm Decolonizing Gender & The Genderpole: Toward a Queer
Abolitionist Framework
. . - » Mx. Noah Green
3:45pm Aging Across Borders: Intergenerational Care and Belonging in
Chinese Transnational Families
» Ms. liahui Lyu 3:45pm Beginning the “End” of the World: Exploring Decolonial and Post-
Capitalist Counternarratives for Life beyond the Anthropocene
4pm “What's Real” on Canal Street: New York’s Shanzhai Fashion » Ms. Marina Rivera Ramos
Economy
» Ms. Victoria Maung
4pm The Time of Politics
3:30pm Black Placemaking and Worldmaking: Space, Power, and Possibility » Dr. Swati Birla
Mini-Conference: Sonic, Cultural, and Festival Geographies
Salon 1 215
-1opm Resistance Agriculture: Memory and futurity in Black and
Palestinian growers’ abolitionist praxis
3:30pm Covering Soca Music - Exploring musical success at the Prof . & Lind P
intersection of race, class and popularity » Prof. Justine Lindemann

» Dr. Meagan Sylvester
3:30pm Presidential Plenary: Worldmaking and World Loss

3:45pm Speculative Geographies of Hip Hop Salon A

» Dr. Joey lennings
3:30pm Teaching and Learning In, About, and Beyond Crisis: Pedagogies of
Organizing and Solidarity

4pm Black Sonic Atmospheres and Biking in Post-Apartheid
Johannesburg Penn Quarter
» Ms. Kristen Miller
3:30pm Teaching and Learning In, About, and Beyond Crisis: Pedagogies of
4:15pm Navigating Pride Festivals While Black and Queer: Arizona Pride Organizing and Solidarity
Festivals 2023-2024 » Prof. John Krinsky, Ms. Hillary Caldwell, Prof. Ben Manski, Prof. Hillary
» Ms. Amina Melendez-Mayfield Lazar, Dr. Nara Roberta Silva

Powered by Ex Ordo, everything you need to run a research conference. Page 49


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST
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5pm

6pm

Robin M. Williams Jr. Distinguished Lecture: Tey Meadow, "The
Structure of Transantagonism: Institutions, Politics, and Social
Control"

Salon A

Reception
Ballroom Floor Atrium

Sunday, 8March

8am

8am

8:15am

8:30am

8:45am

8am

Neighborhoods and Structures of Place
Salon D

Neighborhood Opportunity and Access to Eating Disorder Care:
Structural Barriers in Greater Philadelphia

» Mr. Pascal Beckert-McGirr

The Depoliticization of Neighborhood Associations: The Case of
The CSHCA

» Mr. Evan Witherby

“We’'ll Raise Hell:” Resistance Mythology in an Ethnic Enclave
» Mr. Matt Atwell

The Imminence of Displacement: How Eminent Domain Redefines
Loss of Cultural Capital

» Mx. Lyndsey Saunders

Campus Worlds
Salon C
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8am

8:15am

8:30am

8:45am

8am

8am

8:15am

8:30am

8:45am

8am

Precarious Universities: Exploring the Impacts of the Trump
Administration’s Immigration Executive Orders on Campus Life

» Dr. Anthony |Jimenez, Dr. Wenjie Liao

Student Activism and the University Curriculum: The Case for
Ethnic Studies Programs

» Dr. Miguel Ceballos

Campus Crime and Collective Efficacy: A GIS Analysis of Assault
Patterns at University of Denver and Regis University

» Dr. Anna Curtis, Mr. Parker Arenas

The Bitter Feud Between Brilliant Minds: An Analysis of Factors
Affecting College Student Attitudes Toward Abortion

» Ms. Rachel Chen

lliness & Its Social Organization
Salon 2

“l Heard Cancer, | Heard Death”: How Disclosure Practices
Reproduce Inequality in Healthcare

» Ms. Virginia Leach

TRENDS AND DISPARITIES IN THE INCIDENCE AND MORTALITY OF
BREAST CANCER AMONG WOMEN IN THE U.S. BY AGE AND
RACE/ETHNICITY FROM 2000-2022

» Ms. Esther Oshaji

Moral Tensions and Role Negotiation: The Experiences of Adult-
Child Caregivers and their Parents with Cancer

» Ms. Bernadette Blashill, Dr. Alexi A. Wright, Dr. Anny Fenton

Clerical Task to Policy Concern: Advance Directives, Autonomy,
and Hospice Disparities Among Older Adults

» Ms. Neha |Jangeti

Solidarities, Transformation, and Repair
Salon 1

Page 50


https://www.exordo.com/?utm_source=ess2026&utm_medium=PDF&utm_campaign=PDF

Eastern Sociological Society 05 - 08 Mar 2026 All times in EST

Continued from Sunday, 8 March

8am

8:15am

8:30am

8:45am

9am

8am

8am

8:13am

8:26am

8:39am

Catalyst or Constraint? Grassroots Worldmaking at the Paris 2024
Olympics
» Ms. Sara Lancieri

Adaptive Institutionalization: Navigating Equity Work in
Repressive Contexts

» Ms. ANNA HOWARTH, Dr. James Love

“I'm a better person because of it”: The Experiences of Advocates
for Missing and Murdered Indigenous Peoples in the U.S.

» Ms. Sara Tehrani

Abolitionist Care and Selfhood: Reimagining the Individual in
Prisoner Solidarity Organizing

» Ms. Becca Chalit Hernandez

Toward a Mindful Sociology
» Mr. Sunil Misra

Relational Worlds and Cultural Production

Romance Soaked in Blood: Violent and Taboo Queer Relationships
and their Fans

» Ms. Aidan Valcich

Negotiating Sustainability: Ecological Liminality and
Transformative Practices in Fifth-Generation K-pop

» Dr. yanghwan Choi

The Rise of Para-Social Relationships Online: How Twitch
Performers Deal with Active Audiences

» Mr. Jonathan Fairbanks

Beyond the Hype: American Fans' Appreciations and Reservations
about Korean Pop Culture

» Dr. Dae Young Kim, Dr. Byunghwan Son
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8am

8am

8:15am

8:30am

8:45am

8am

8am

8:15am

8:30am

8:45am

Health and Behavioral Outcomes
Salon B

Place Matters: 2020 Aggregated Drinking Rates for Selected
(MMSAs)

» Dr. Stephanie Bennett-Knapp

Partners’ Drinking and Harm at Home: DHS Evidence Across
Countries

» Ms. Raven James, Dr. Elena Chernyak, Dr. Ryan Ceresola

Parental Smoking and Spillover Consequences for Adolescents’
Risk Behaviors, Substance Use, and Immune Health

» Ms. Jasmine Aboumahboob

Contextualizing Empowerment: The Mental Health Significance of
Donald Trump’s 2024 Re-election for White Male Veterans.

» Dr. Julian Culver, Dr. Quintin Gorman

Contested Terrains & Moral Claimsmaking
Salon A

Manufacturing Morality: Legitimacy and the Prison Industrial
Complex

» Dr. Emily Estrada

The Dynamic Ravine between Corporations and the State: Meat
Industry Navigation of Immigration Policy in the Awful Years

» Dr. Ivy Ken, Dr. Kenneth Leon

Sex Work as an Ethical Choice: Moral Agency in OnlyFans Adult
Content Work

» Ms. Changhye Ahn

Evaluating the Mental and Physical Implications of Solitary
Confinement on Formerly Incarcerated Individuals

» Ms. Riley von Borstel
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8am

8am

8:13am

8:26am

8:39am

8:52am

8am

8am

8am

When Relational and Digital Worlds Intersect
London 1

Repairing the Frame: A Visual Autoethnography of Generational
Trauma and Collective Memory through Reconstructed Family
Photographs

» Dr. Josephine Barnett

Understanding the Invisible Social Context Around Receiving
Unsolicited Nude Photographs

» Dr. Meghan Murph

Examining “Al art” as a reflection of alienation in post-modern
capitalism

» Mr. Teagan Helsing

Exploring Sibling Victimization by Sisters Through Online Forum
Posts

» Ms. Kay Sassan, Dr. Tanya Rouleau Whitworth, Dr. Corinna Jenkins
Tucker

More than Video Games: Insights from David Riesman on
loneliness, anxiety, and creativity

» Dr. Marcus Aldredge

ESS Executive Committee Meeting
Tokyo

Decolonial Sociology in Times of Resistance Mini-Conference:
Abolitionist Politics and Decolonial Social Movements

Salon 3

From Militancy to Mobility- Rethinking Decolonial Resistance in
Kashmir

» Mr. Muzaffar Ahmad
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8:15am

8:30am

8:45am

9:30am

9:30am

9:43am

9:56am

10:09am

10:22am

9:30am

Decolonial Imagination and Practice: Mutual Aid in Political
Witchcraft and Kashmiri Scholar-Activism

» Ms. Apoorvaa |oshi

Undesirable Radicalism: On Anti-Blackness, Abolition, and an
Endurance that Wounds

» Mx. Dalton Lackey

Insurgent Intimacies: Baloch Women and the Making of
Resistance

» Ms. Mahso Gichki

Digital Navigations
Penn Quarter

Why TikTok Matters: New Directions in Sociological Methods for
the Digital Age
» Ms. Cristiana Miele, Mr. |ack Exline, Ms. Kate Freeman

Through the looking glass: algorithmic worldmaking and identity
in content recommendation systems

» Mr. Taylor Beauvais

The Minimalist Lifestyle as a Coping Mechanism for
Neurodivergence

» Ms. Laura Golden

Hidden Voices, Visible Ideologies: A Critical Discourse Analysis of
Campus Discourse on Yik Yak

» Dr. Zachary McKenney, Ms. Silence Baggesse, Mr. Cooper Cohen, Ms.
Ruby Divris, Mr. Logan Hehner, Ms. Adilyam Imyarova, Mx. Indigo

Shepard, Ms. Julia Weinschreider

Feeling Rules and Emotion Management: Gender and Race in
Video Game Streaming

» Dr. Katherine Bullock

Social Infrastructures and Belonging
Salon C
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9:30am

9:45am

10am

10:15am

9:30am

9:30am

9:43am

9:56am

10:09am

Enabling "Accessibility" in Libraries: The Case of Vermont State
University

» Dr. |ennifer Lai

“A place where people are:” Organizational flexibility and the
public library as a third place

» Mrs. Lydia Orr

“But Is It Feminist?” The Highlights, Challenges, and Opportunities
of Creating a Sociological and Transdisciplinary Podcast

» Dr. Amanda Hernandez

Feeling the Flow: Embodiment, Environment, and Open-Water
Swimming in the Chesapeake Bay

» Dr. Jacob Bustad

Economic Markets & Stratifying Processes
Tokyo

Discretion Displaced: State, Market, and the Birth of Shadow
Banking

» Mr. Wenhao Song

The Shareholder Primacy Myth as Symbolic Power: Executive
Discourse in the Health Insurance Industry

» Mr. Pascal Beckert-McGirr

Cooking Inequality: How The Peruvian Gastronomy
Professionalization Reshaped Stratification Within the Culinary
Labor Market (2008-2023)

» Mr. Juan Dolores Cerna

The State’s Moral Stamp of Approval: Bureaucratic Moral
Brokerage in the Eldercare Tech Market

» Ms. Nayun Eom
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10:22am

9:30am

9:30am

9:45am

10am

10:15am

9:30am

9:30am

9:30am

9:30am

Arts Distribution and Its Effects
» Dr. Nicholas Dempsey

Health and Education (Sponsored by Committee on Gender Equity)
Salon D

Centering Intersectional Gender Equity Strengthens Higher
Education: Equitable Faculty Collaboration and Institutional
Resilience

» Prof. Laurel Smith-Doerr, Prof. |Joya Misra, Dr. Elisa Martinez

Who reports good health in India: A study of caste, gender and
health outcomes in India

» Mr. Satadru Bhattacharyya

Identity Narratives at the Intersection of Autism and Gender
» Dr. Nic Rios

“Being Black is a challenge... Being gay on top of that, got damn*:
Black Queer Women's Experiences in Lower and Higher
Educational Settings

» Ms. Amina Melendez-Mavfield

AMC: The Not So Outrageous Idea Of A Christian Sociology, by
Joseph A. Scimecca. Routledge, 2024

Salon B

The Not So Outrageous Idea Of A Christian Sociology, Joseph A.
Scimecca. Routledge, 2024

» Dr. Joe Scimecca, Dr. Mariam Kurtz, Dr. Arnold Sherman, Dr. Gaurav
Pathania, Dr. Paul Sullins

AMC: Major Trade-Offs: The Surprising Truths about College Majors
and Entry-Level Jobs, by Corey Moss-Pech

Major Trade-Offs: The Surprising Truths about College Majors and
Entry-Level Jobs by Corey Moss-Pech

» Dr. Corey Moss-Pech, Dr. Amy Binder, Dr. Anthony Jack, Prof. Tim
Bartley, Dr. Blake Silver
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9:30am

9:30am

9:45am

10am

9:30am

9:30am

9:45am

10am

9:30am

9:30am

Trust, Communities and Individualism
London 1

Trust amongst Generation Z: Results from a Nationally
Representative Survey of 15-29 Year Olds

» Dr. Todd Matthews, Dr. Eleni Mantas-Kourounis

God and the Grid: Religious Trust and Spiritual Environmentalism
in Tension

» Dr. Timothy Dacey

One Nation, Many Teams: Americans’ Attitudes About Sport as a
Unifier or Divider in Society

» Mr. Rylan Hastings

Adaptation and Community Transformation
Salon 2

Exploring Experiences of Christians in Contemporary China: A
Qualitative Study

» Ms. Wei Wan

Undocumented Filipinos in New England: Building Community
Resilience in the Shadows

» Ms. Joy C. L. Solon, Mr. Juan Carlo Gaspar

Marxism in Modern China: Adaptation and Transformation
» Mr. Andrew Sher, Dr. Elena Chernyak

Black Placemaking and Worldmaking: Space, Power, and Possibility:

Diaspora, Migration, & Transnational Placemaking
Salon 1

Diaspora Brokers and the Paradoxes of Return: Black American
Repatriation and Nation-Building in Ghana

» Mr. David Curtiss
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9:45am

10am

10:15am

9:30am

9:30am

9:45am

10am

10:15am

T1am

T1am

Black Ethnic Placemaking: Somali Refugee Neighborhoods and
Black Urban Traditions

» Dr. Nima Dahir

‘There's been a village of support’: Black immigrant placemaking
in a Midwestern city

» Ms. Lisa Oyolu, Dr. Jessica Stovall

Worldmaking within the Carcerality of Black Worldlessness: A
Toronto and Peel Region Case Study

» Dr. Beatrice Anane-Bediakoh

Decolonial Sociology in Times of Resistance Mini-Conference: Art
and Resistance Against Empire

Salon 3

Jab Jab in Grenada: Race in Resistance and Reimagination
» Ms. Leana Mason

#miBlusaDeTlahui: Fashion Industry, Indigeneity, and Creativity
» Mr. Danny Daniel Mollericona Alfaro

La Casita y La Loma: Bad Bunny'’s Creation of Cultural Objects to
Forge Latine Solidarity

» Dr. Karolina Dos Santos, Dr. Katie Duarte

Unbordering the Self: Artistic Agency and Making of New Kurdish
Subjectivity

» Ms. Sena Kaplan

Parental Impacts & Education
Tokyo

Social Class, Immigration Status, and Parental Cultural Knowledge
Transmission for University Students

» Mr. Bruce Liang
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11:15am

11:30am

11:45am

T1am

T1am

11:13am

11:26am

11:39am

11:52am

Parents’ perspectives about priorities in education
» Dr. Erin Michaels

Beyond Involvement: Exploring the Effects of Parents’
Professional Backgrounds on Children’s Math Achievement

» Ms. Yi Lan

Aligned, Compliant, or Defiant: Social Science Teachers’ Responses
to the Parental Rights Movement and Associated Policies in
Florida

» Ms. Hannah Castner

Sexual Identities & Structures of Belonging
Salon D

“We're all struggling”: How LGBTQ adults navigate the
consequences of ambivalent belonging in romantic relationships,
local community, and family ties

» Dr. Bailey Troia

There in My Time of Need: Identity Support and Queer Fictive
Kinship
» Mx. Max Calleo

Where's the beef ™?
» Ms. Rachael Gonzales

Sexuality in the Ocean State: Understanding Sexual Identity and
Place Identity in Rhode Island

» Dr. Julie Keller, Dr. Melanie Brasher

Rethinking Intimacy Beyond Sex: Nonsexual Relationships in
Contemporary China

» Ms. Xi Cao
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11am

T1am

11:13am

11:26am

11:39am

11:52am

11am

T1am

11:15am

Encounters in Higher Education
Salon C

Why First-Year Students Leave: Investigating Factors Driving
College Attrition Patterns at a Public, Urban College in the
Northeast

» Ms. Syeda Shampa Chowdhury

The Paradox of Flexibility: Honors Education and Students'
Educational Pathways

» Ms. Alyssa Cazier, Mr. Lawrence Bullard, Ms. Dina Berenshteyn-
Barger, Mr. Madhav Maniraj, Dr. Blake Silver

The Paradox of Expertise: How independent education agencies
un/serve wealthy Chinese families preparing for overseas
education

» Ms. Ruiyi Li

Pathways to College Majors: Decomposing the Effects of Family
Background through High School STEM Experiences

» Ms. Jingzhi Guo, Dr. Simon Cheng, Dr. Mary Fischer

Managing the Demands of Community-Engaged Learning:
Developing Student Leadership to Strengthen College-Community
Partnerships

» Dr. Laura Steck

Perspectives on Law and Legality
Penn Quarter

Legal Socialization, Legal Cynicism, and Countersurveillance in
Los Angeles During Heightened Immigration Enforcement

» Dr. Luis Tenorio

The Intersectional Dilemma of Family Law and Immigration Law
for Victimized Immigrants of the United States

» Ms. Yi Rong
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11:30am

11:45am

11am

T1am

11:15am

11:30am

11:45am

12pm

T1am

T1am

Legal Legitimacy: Conceptions of Legality and Membership among
Temporary Migrants, 2007-2021

» Dr. Michelle Dromgold-Sermen

The (Im)Possibility of Black Emotional Rights: A Comparative
Analysis of Three Police Violence Trials

» Dr. Shantee Rosado, Mr. Devin Williams

Cultural Liminalities and Gender Transformations
London 1

Mid-Life Women and Emancipatory Divorce in the United States
» Ms. Caty Borum

“We Are Not a Co-Ed Team but We're a Co-Ed Team”: Women
Athletes in Mixed-gender Environments

» Prof. Catherine Berheide, Ms. Yirui Tang, Ms. Yue Chen

Palestinian Women, The Heart of Resiliency
» Ms. Abrar Beitazzam

Detoxifying the Self: Gendered Governance through Yoga and
Fermented Nutrition in China

» Ms. Ying Qu

Femininities and Disabilities: The Diversity of Femininities of
Black American Women with Disabilities

» Ms. Mehtia Lee, Dr. Ying-Chao Kao

Race and Racism
Salon B

The Inclusion Tax Scale: Development and Initial Validation
» Dr. Tsedale M. Melaku
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11:13am

11:26am

11:39am

11:52am

11am

T1am

11:15am

11:30am

11am

T1am

The Brown Label: Contemporary Understandings of the Racial
Color Line(s)

» Ms. Katerine Perez

Structural Gendered Racism, Coloniality, and Resistance: The Case
of Diasporic Puerto Ricans

» Dr. Janelle Ashley Viera

Racism and Woke-ism: Discourse about the WNBA
» Dr. Rod Carveth

How Black Women Harm Black Women
» Mr. Tyshawn Smithers

#Me Too and Labor (Sponsored by Committee on Gender Equity)
Salon A

The Game Within the Game: How Women Navigate and Label
Workplace Harassment in the #MeToo Era

» Dr. Shekinah Hoffman

“A big moment for change in this industry,” An Analysis of
Hollywood Workspace Dynamics in the Aftermath of the #MeToo
Movement

» Ms. Courtney Bell

How Declining Financial Status Shapes Gender Attitudes
» Prof. Katharine Khanna

AMC: Creating Life Before Death: Before Disaster Strikes the Ship of
State, 2nd edition, by Dr. Andrew Plotkin, Dr. Bernard Phillips, and
Dr. Neil Weissman

Salon 2

Critics Meet the Authors of Creating Life Before Death: Before
Disaster Strikes the Ship of State, 2nd edition, 2025, Sarasota, FL:
Sociological Imagination Movement

» Dr. Andrew Plotkin, Dr. Bernard Phillips, Dr. Neil Weissman
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T1am

T1am

11:15am

11:30am

11:45am

11am

12:30pm

12:30pm

12:45pm

Black Placemaking and Worldmaking: Space, Power, and Possibility:

Schools, Services and Worlds of Care
Salon 1

Culture, Community, and Curriculum: How Institutional Contexts
Matter for Black Collegians

» Ms. Sagen Kidane

Saving a Seat for You and Me: How Black Women Student Leaders
Uphold Community Spaces for Themselves and Others on Campus

» Ms. Imani Smith

Building Worlds of Access: Community Hubs as Infrastructures of
Repair and Collective Empowerment

» Ms. Elizabeth Sanchez

Chosen Family: How Fictive Kinship Relationships Are Holistically
Sustaining Black Educators

» Mx. Zariah Nicole

Decolonial Sociology in Times of Resistance: Reflections, next mini-
conference theme, and networking

Salon 3

Crisis & Dystopian Worlds
Salon 2

Examining Colonialism, Honor, and Running Amok in Southeast
Asia: Lessons for Contemporary Explanations of Mass Public
Shootings in Neoliberal America

» Dr. Luigi Esposito, Dr. Fernando Perez

The Janus Face of Social Darwinism: Survivalist Reception in Asia’s
Encounter with Western Power

» Dr. Xuewen yan
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Tpm

1:15pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

12:45pm

“By fire, be purged!”: The Necessity of Countering Alt-right
Extremism in World of Warcraft

» Mx. Serena Abdallah-Robbins

Society in Crisis: Dystopian Realities, the Presence of Resistance
and the Struggle for Society.

» Prof. Eric Lichten

Inequality Regimes and Organizational Contexts
Salon D

Gender composition, skill valuation, and wage inequality in the
United States labor market

» Mr. Khe'-G Baron, Dr. Kristin Smith

Gender Gaps in Environmentalism: Analysis of the 1993, 2000,
2010, and 2021 General Social Surveys

» Ms. Kelsey Gaylord

How does inflation influence consumerism differently across
racial and ethnic groups in the United States?

» Ms. Maria Rodriguez

Identifying and reducing inequities in the effects of
implementation of firearms policies

» Dr. |essica Welburn Paige, Dr. Dionne Barnes-Proby

Barriers to Wellbeing
Salon C

Neurological, Immunological, and Optical Consequences of Sexual
Abuse by Race-Gender Status

» Ms. Akeva Koulla, Dr. Ryan Talbert

Weathering Violence: Emergency Department Presentations for
Sexual Assault Amidst Heavy Snowfall

» Dr. Natalie Jansen
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Tpm

1:15pm

12:30pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

Internalized and Interpersonal Stigmas: Trauma Survivor
Perceptions of Impacts on Health and Recovery

» Ms. Paige DePasquale, Dr. Amantia Ametaj, Dr. Arielle Scoglio, Dr.
Alisa Lincoln, Ms. Suzanne Garverich, Ms. Alyssa Fuller, Mr. Rohan
Chopra, Ms. Jasmine Elsayed, Ms. Julisa Fernandez-Rivera, Ms. Rabiya
Jaffry, Ms. Chloe Mak, Ms. Daphney Mirand

Cancer in a Foreign Land: Language Barriers in Patient-Reported
Experiences of Breast Cancer Patients in Germany

» Prof. Susan Lee, Prof. Holger Pfaff, Prof. Lena Ansmann

State Navigations and State Processes
Penn Quarter

Social Constraints & Cultural Processes
Tokyo

Mexican Marital Partnering: Exploring Educational Assortative
Mating among Legal Immigrants from Mexico to the United States

» Dr. Veena S. Kulkarni

Downstream Economic Consequences of Parental Educational
Attainment

» Prof. Ryan Sperry, Ms. Fariha Hossain, Ms. Oluchukwu Nkenke, Ms.
Afsana Siddika

Self-Rated Health and Inter-Racial Interaction Among Asian
American Immigrants

» Mr. SHUHAO CHANG, Ms. Man-Lin Chen

Invisible Pain: Public Perception of Marital Rape Survivors in
China

» Dr. Ya Su, Dr. Yifeng Wan

Nationalist Struggles and Worldmaking
Salon 1
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12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

12:30pm

Nationalist public opinion in the US: Worldmaking or
Worlddestroying?

» Dr. Josh Klein

Democratic Worldmaking under Empire: Women's Suffrage in the
Grand Duchy of Finland of the Russian Empire

» Dr. Juho Korhonen, Dr. Keenan Wilder

Nas: the Struggle for identity for former-Yugoslavian Muslims
» Ms. Amina |avorovac

Adorno, Foucault and National Identity
» Mr. Daniel Rogers

Housing, Displacement, and Inequality
London 1

The Changing Profile of Homeowners in the United States, 1989 -
2022

» Prof. Joseph Cohen, Ms. Syeda Shampa Chowdhury

Dollar-Denominated Empirical Estimates of Household Economic
Inequality with the SCF

» Prof. Joseph Cohen

Examining Household Vulnerabilities to Prolonged Displacement
following a Natural Disaster

» Mr. Wyatt Taylor

"So what chance, what opportunities do we have?" Homeowners
associations as racialized organizations

» Dr. Stephanie Dhuman, Ms. Tillie Germain

Campus Belonging and Social Inequalities
Salon B
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12:30pm

12:45pm

Tpm

1:15pm

12:30pm

12:30pm

12:45pm

Tpm

1:15pm

Rhythms of Resistance: The Role of Institutions and Cultural
Expressions in Latinx College Students’ Cultural Affirmation
Processes

» Ms. Manuella Escobar, Dr. Gabriela Leon-Perez

Intersecting Identities, Unequal Outcomes: How Race, Gender,
and SES Shape College Degree Attainment

» Dr. Kristine Rosales

Making Sense of Inclusion: College Students’ Interpretations of
Pronoun Policies

» Mr. |effery White, Mr. Tucker Reyes, Dr. Mary Nell Trautner

Place as Text as a Pedagogical Tool for Introductory Sociology
Courses

» Dr. Jason Milne, Dr. JoEllen Pederson

Political Processes
Salon A

Red States, Hidden Hate? The Politics of (Under)Reporting Hate
Crimes in the Trump Era

» Mrs. Mya Garcia

The Politics of Assistance: USAID and the Practice of Neo-colonial
Control

» Mr. Andrew Sher

The Fiscalization of Politics: Budget Talk as Political Justification in
U.S. Congress, 1921-2024

» Mr. Terrence Chen

Profiling Authoritarian Leaders

» Ms. Coraima |imenez Lopez
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12:30pm

12:30pm

12:43pm

12:56pm

1:09pm

1:22pm

2pm

2pm

2:15pm

2:30pm

Community Wellbeing and Health
Salon 3

Latina Maternal Health in Southeastern Pennsylvania:
Immigration Status, National Origin, Acculturation, and
Postpartum Depression

» Dr. Miguel Ceballos, Dr. Leon Arredondo

Perceived Neighborhood Characteristics and Cognitive
Functioning Among Older Adults: A Longitudinal Study

» Ms. Yuchen Gu

How Small Business Ownership Affects Immigrants Mental Health
» Ms. Margelys Garcia

The Community Determinants of Drug Overdose Deaths: Census-
tract level Predictors in Miami-Dade County, 1989 to 2011

» Ms. Katrina Shonka, Prof. Ramiro Martinez

Migration Experience and Self-Rated Health in China: Cross
-Sectional Evidence from the 2018 CLHLS Survey

» Ms. liangnan Liu

Work & Education
Salon 3

Pay Attention: Compensation Salience and the Sorting of
Adolescent Occupational Expectations

» Mr. Matthew Saxton

Finally getting on the right track: Student debtors’ career
ambivalence and regret

» Dr. Joan Maya Mazelis

Unlocking Opportunities: Networking Strategies for First
Generation Scholars

» Dr. Bedelia Richards
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2:45pm

2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

2pm

2:15pm

2:30pm

The effects of full-day childcare on low-income mothers’
employment and school enroliment

» Ms. Rebecca Bier

Adaptations and Organizational Processes
Salon D

Private Investment in Military Neurotrauma Technology: National
Security Risks and Policy Considerations

» Dr. Sandya Venugopal

New Perspectives on the Organization of Military Sociology
» Dr. Guy Siebold

An International, Systematic Review of How Hospitals Manage
Patient Health Literacy

» Ms. Amy Romanauski, Dr. Brian Gran

Mortal Catharsis: Burnout, Stress, and Meaning in the Care of the
Dying
» Dr. Timothy Elder

Labor Processes
Salon C

Compositional and Scale Effects: How Foreign Direct Investment
Shapes Informal Labor Market in Latin America, 2000-2018

» Mr. Ang Li

Beyond Social Closure: Licensure as a Tool of Differentiation
» Dr. Heba Alex

Analyzing Credibility in Workplace Discrimination Claims Using
Large Language Models (LLMs): Evidence from the Massachusetts
Commission Against Discrimination (MCAD)

» Ms. Chenxi Yuan

Powered by Ex Ordo, everything you need to run a research conference.

2:45pm

2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

2pm

2:15pm

2:30pm

The Political Economy of Drywall
» Prof. Albert Fu

Campus Contentions
Salon 1

Taking It to The Streets: Dream Promoters, Community
Engagement and Leadership in a University-Community
Partnership

» Dr. Jeffry Will

Peacebuilding and International Branch Campuses
» Prof. Lester Kurtz, Mr. Benjamin Adjei, Mr. Md al Ifran Hossain Mollah

"Fake Written All Over You": Power, Privilege, Promotion and
Tenure

» Dr. Ryan King White, Dr. Tara Blackshear

The collegiate conspiracist: How education affects beliefs in
conspiracy theories from 2012 - 2024

» Dr. Ryan Ceresola, Mr. Andrew Sher

Political Technologies
Salon 2

From Surplus Value to Surplus Consciousness: A Hegelian-Marxist
Critique of Algorithmic Alienation

» Mr. JUNHUAN [IN

Time Under Technocapitalism
» Mx. Olivia Zinn

It's Not a Lie if You Believe It: Donald Trump’s Gonzo Expertise as
Dramaturgical Performance

» Dr. R| Maratea
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2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

2pm

2:13pm

2:26pm

2:39pm

Boundary-making, Meaning-making
Salon A

“One Hundred Percent of the Money:” Empower's Empty
Rideshare Revolution

» Ms. Camille McGinnis

Learning, Performing and Reproducing Beauty Hierarchy: An
Ethnographic Study of a K-pop Cover Dance Team in Hong Kong

» Ms. Wanying Zhou

Latino Group Conceptions and Ethnic Boundary-Making
» Mr. Keitaro Okura

The Structure of Motivation for Spiritual Practices: The Meanings
of the Hungry Ghost Festival in China

» Dr. Becky Hsu, Dr. Liu Zhuang

Group Boundaries and Identity Process
Tokyo

The Construction of Children’s Play in Marginalized Children’s and
Youth Centers in Taiwan.

» Ms. Pei-Chen Cheng

The Perception of the West Under Threat: American Attitudes on
China

» Mr. Aris Morgan

THE ROLE OF PRIMARY GROUPS IN UKRAINIAN REFUGEES'
RESOCIALIZATION AND INTEGRATION IN THE US

» Dr. Halyna Lemekh

Defining the ‘Good Student”: How Preschool Logics Imagine
Student-Teacher and Student-Learning Relationships

» Dr. Hannah Espy

Powered by Ex Ordo, everything you need to run a research conference.

2:52pm

2pm

2pm

2:15pm

2:30pm

2:45pm

2pm

2:15pm

2:30pm

Fluid Identities, Malleable Attitudes: Non-persistent Attitude
Change in Unsettled Lives

» Dr. Chaeyoon Lim, Mr. Yoonyoung Na

Governance, Rights, and Repair
Salon B

(Eco)Worldmaking Via Connecting to Nature
» Dr. Daniel McLane

People Power and the Adoption of Rare Constitutional Human
Rights

» Mr. Tom Wells

From Principle to Percentile: Poverty Guidelines and the
Metrication of Indigency, 1985-2025

» Prof. Kevin Dahaghi

Speciesism and Academia: An Inquiry of Ethics, Equality, and the
Human-Species Divide

» Ms. Kesha Loftus

Considering Disciplinary Methods and Measurement
Penn Quarter

Population science implications of the inclusion of stillbirths in
demographic estimates of child mortality

» Dr. Payal Hathi

Testing the Empirical Performance of Popular Generation Labels:
A Comparative Age-Period-Cohort Analysis

» Prof. Andrew Lindner

Metaphors and Models in the Social Sciences
» Dr. Oyman Basaran
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Continued from Sunday, 8 March 4pm Cheating or Saving Time? Student Perceptions of Al Use at a
Liberal Arts College

» Dr. Brent Harger

2:45pm "Resuscitating Psychoanalytic techniques if not doctrines into the
formulation of sociological theories and possibly suggested 4:15pm Beyond Consent: How Generative Al Creates Post-Consensual
trammg... Social Relations
» Mr. David (led) D. Schwartz » Prof. Jill Weinberg, Prof. Joong Won Kim
2pm Social Contexts of Mental Health 3:30pm Panel: Immigration in a Changing Metropolitan Landscape
London 1 Salon A
2pm Time Use, Social Participation, and Depressive Symptoms in Later 3:30pm Immigration in a Changing Metropolitan Landscape
Life » Mrs. Hannah Wingo, Ms. Olivia Salamone, Ms. Quinn Pierson, Mr.
» Ms. Wenyi Gong Marshall Plane
2:15pm Barriers to Accessing Mental Health Care for First-Generation 3:30pm Youth Relational Worlds
Immigrants in the United States with Serious Mental lliness: A Tokyo
Systematic Literature Review
» Ms. Tayler Rochester, Dr. Margaret Leigey, Mr. Kevin Hoppe, Ms. 3:30pm Dating and Intimacy in the Philippines: Gender Differences among
Miriam Maburi, Ms. Gabriela Salmeron, Ms. Brennan Tosney, Dr. Sylvia Young Adults
Twersky » Dr. Louie Benedict R. Ignacio, Dr. Sampson Blair, Dr. Clarence M.
Batan
2:30pm Weight discrimination, mental health, and the protective role of
social resources 3:45pm Risk-Taking and School Performance
» Dr. Sadie Ridgewa » Dr. Timothy Madigan, Dr. Sampson Blair
2:45pm The role of police exposure and contact on academic well-being 4pm From Adversity to Optimism: The Relationship Between Adverse

Childhood Experiences and Optimism in Young Adulthood

» Ms. Sagen Kidane, Ms. Andrea Constant
» Mrs. Miranda Habrecht, Mr. Devon Skufca

3:30pm Al & Its Discontents
P 4:15pm When No Means Yes: Exploring the Factors Behind Participation in

Consensual Non-Consent (CNC)

3:30pm Screened Out! Artificial Intelligence, Hiring Bias, and the New » Ms. Sophia Fleischer. Prof. Richard Zdan
Inequality So-obolia e saher '

» Dr. H. Lovell Smith

3:45pm Selective Secrecy: Teachers Navigating the Integration of
Generative Al at City Elementary

» Mr. Anderson de Andrade
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